summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/peg-e/peg-e-1.2.5.ebuild')
-rw-r--r--games-board/peg-e/peg-e-1.2.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/games-board/peg-e/peg-e-1.2.5.ebuild b/games-board/peg-e/peg-e-1.2.5.ebuild
new file mode 100644
index 000000000000..e53cb97a9303
--- /dev/null
+++ b/games-board/peg-e/peg-e-1.2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit desktop gnome2-utils qmake-utils
+
+DESCRIPTION="A peg solitaire game"
+HOMEPAGE="https://gottcode.org/peg-e/"
+SRC_URI="https://gottcode.org/peg-e/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}