summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/xgammon')
-rw-r--r--games-board/xgammon/xgammon-0.98-r3.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/games-board/xgammon/xgammon-0.98-r3.ebuild b/games-board/xgammon/xgammon-0.98-r3.ebuild
index 6b1305059c62..b5c4afd2beec 100644
--- a/games-board/xgammon/xgammon-0.98-r3.ebuild
+++ b/games-board/xgammon/xgammon-0.98-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="very nice backgammon game for X"
HOMEPAGE="http://fawn.unibw-hamburg.de/steuer/xgammon/xgammon.html"
@@ -21,6 +21,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
S="${WORKDIR}/${P}a"
@@ -33,8 +34,10 @@ PATCHES=(
)
src_configure() {
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
+
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {