summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch80
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch86
-rw-r--r--games-board/pokerth/pokerth-1.1.1-r2.ebuild16
3 files changed, 177 insertions, 5 deletions
diff --git a/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch b/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch
new file mode 100644
index 000000000000..ab112e831a0c
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-boost-noexcept.patch
@@ -0,0 +1,80 @@
+Keep dynamic exception specifications in sync with boost.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=603354
+
+--- a/src/third_party/websocketpp/websocketpp/error.hpp
++++ b/src/third_party/websocketpp/websocketpp/error.hpp
+@@ -122,7 +122,7 @@
+ public:
+ category() {}
+
+- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ char const * name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/extensions/extension.hpp
++++ b/src/third_party/websocketpp/websocketpp/extensions/extension.hpp
+@@ -62,7 +62,7 @@
+ public:
+ category() {}
+
+- const char *name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ const char *name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.extension";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/processors/base.hpp
++++ b/src/third_party/websocketpp/websocketpp/processors/base.hpp
+@@ -159,7 +159,7 @@
+ public:
+ processor_category() {}
+
+- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ char const * name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.processor";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/transport/asio/base.hpp
++++ b/src/third_party/websocketpp/websocketpp/transport/asio/base.hpp
+@@ -202,7 +202,7 @@
+ /// Asio transport error category
+ class category : public lib::error_category {
+ public:
+- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ char const * name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.transport.asio";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/transport/asio/security/base.hpp
++++ b/src/third_party/websocketpp/websocketpp/transport/asio/security/base.hpp
+@@ -102,7 +102,7 @@
+ /// Error category related to asio transport socket policies
+ class socket_category : public lib::error_category {
+ public:
+- const char *name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ const char *name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.transport.asio.socket";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/transport/base/connection.hpp
++++ b/src/third_party/websocketpp/websocketpp/transport/base/connection.hpp
+@@ -179,7 +179,7 @@
+ public:
+ category() {}
+
+- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ char const * name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.transport";
+ }
+
+--- a/src/third_party/websocketpp/websocketpp/transport/iostream/base.hpp
++++ b/src/third_party/websocketpp/websocketpp/transport/iostream/base.hpp
+@@ -64,7 +64,7 @@
+ public:
+ category() {}
+
+- char const * name() const _WEBSOCKETPP_NOEXCEPT_TOKEN_ {
++ char const * name() const BOOST_SYSTEM_NOEXCEPT {
+ return "websocketpp.transport.iostream";
+ }
+
diff --git a/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch b/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch
new file mode 100644
index 000000000000..aebf2b0ab946
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-qmake-gcc-6.patch
@@ -0,0 +1,86 @@
+From: Markus Koschany <apo@debian.org>
+Date: Tue, 23 Aug 2016 17:50:52 +0200
+Subject: qmake gcc-6
+
+---
+ chatcleaner.pro | 1 -
+ pokerth_db.pro | 1 -
+ pokerth_game.pro | 1 -
+ pokerth_lib.pro | 2 +-
+ pokerth_protocol.pro | 1 -
+ pokerth_server.pro | 1 -
+ 6 files changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/chatcleaner.pro b/chatcleaner.pro
+index 6d63b4a..56070d8 100644
+--- a/chatcleaner.pro
++++ b/chatcleaner.pro
+@@ -49,7 +49,6 @@ win32 {
+ !win32{
+ ##### My release static build options
+ #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
+- INCLUDEPATH += $${PREFIX}/include
+ }
+ mac {
+ # make it x86_64 only
+diff --git a/pokerth_db.pro b/pokerth_db.pro
+index 7c2d142..c524ee3 100644
+--- a/pokerth_db.pro
++++ b/pokerth_db.pro
+@@ -49,7 +49,6 @@ win32{
+ !win32{
+ ##### My release static build options
+ #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
+- INCLUDEPATH += $${PREFIX}/include
+ }
+
+ mac{
+diff --git a/pokerth_game.pro b/pokerth_game.pro
+index e3ddb03..e0e8660 100644
+--- a/pokerth_game.pro
++++ b/pokerth_game.pro
+@@ -404,7 +404,6 @@ unix:!mac {
+ # #### My release static build options
+ # QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
+ # QMAKE_LFLAGS += -Wl,--gc-sections
+- INCLUDEPATH += $${PREFIX}/include
+ QMAKE_LIBDIR += lib
+ !android{
+ LIBPATH += $${PREFIX}/lib /opt/gsasl/lib
+diff --git a/pokerth_lib.pro b/pokerth_lib.pro
+index 6db489d..498d06e 100644
+--- a/pokerth_lib.pro
++++ b/pokerth_lib.pro
+@@ -243,7 +243,7 @@ win32{
+ !win32{
+ ##### My release static build options
+ #QMAKE_CXXFLAGS += -ffunction-sections -fdata-sections
+- INCLUDEPATH += $${PREFIX}/include /opt/gsasl/include
++ INCLUDEPATH += /opt/gsasl/include
+ }
+
+ mac{
+diff --git a/pokerth_protocol.pro b/pokerth_protocol.pro
+index 7a331df..2ead0ec 100644
+--- a/pokerth_protocol.pro
++++ b/pokerth_protocol.pro
+@@ -33,7 +33,6 @@ win32 {
+ DEFINES += _WIN32_WINNT=0x0501
+ }
+ unix : !mac {
+- INCLUDEPATH += $${PREFIX}/include
+ system(protoc pokerth.proto --cpp_out=src/third_party/protobuf)
+ system(protoc chatcleaner.proto --cpp_out=src/third_party/protobuf)
+ system(protoc pokerth.proto --java_out=tests/src)
+diff --git a/pokerth_server.pro b/pokerth_server.pro
+index 706475f..43b30f3 100644
+--- a/pokerth_server.pro
++++ b/pokerth_server.pro
+@@ -174,7 +174,6 @@ unix : !mac {
+ #QMAKE_LFLAGS += -Wl,--gc-sections
+
+ LIBPATH += lib $${PREFIX}/lib /opt/gsasl/lib
+- INCLUDEPATH += $${PREFIX}/include
+ LIB_DIRS = $${PREFIX}/lib $${PREFIX}/lib64 $$system(qmake -query QT_INSTALL_LIBS)
+ BOOST_FS = boost_filesystem boost_filesystem-mt
+ BOOST_THREAD = boost_thread boost_thread-mt
diff --git a/games-board/pokerth/pokerth-1.1.1-r2.ebuild b/games-board/pokerth/pokerth-1.1.1-r2.ebuild
index 32febcde5511..3c3d0666db4d 100644
--- a/games-board/pokerth/pokerth-1.1.1-r2.ebuild
+++ b/games-board/pokerth/pokerth-1.1.1-r2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
-inherit flag-o-matic eutils qmake-utils
+
+inherit eutils flag-o-matic qmake-utils
MY_P="PokerTH-${PV}-src"
DESCRIPTION="Texas Hold'em poker game"
@@ -40,12 +41,14 @@ S=${WORKDIR}/${MY_P}
PATCHES=(
"${FILESDIR}/${P}-qt5.patch"
"${FILESDIR}/${P}-boost-1.60.patch"
+ "${FILESDIR}/${P}-qmake-gcc-6.patch"
+ "${FILESDIR}/${P}-boost-noexcept.patch"
)
src_prepare() {
default
- if use dedicated ; then
+ if use dedicated; then
sed -i -e 's/pokerth_game.pro//' pokerth.pro || die
fi
@@ -58,13 +61,16 @@ src_configure() {
src_install() {
dobin bin/pokerth_server
- if ! use dedicated ; then
+ if ! use dedicated; then
dobin ${PN}
insinto /usr/share/${PN}
doins -r data
domenu ${PN}.desktop
doicon ${PN}.png
fi
+
+ einstalldocs
+ dodoc docs/{gui_styling,server_setup}_howto.txt
+
doman docs/pokerth.1
- dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
}