summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch11
-rw-r--r--games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild6
2 files changed, 16 insertions, 1 deletions
diff --git a/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch b/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch
new file mode 100644
index 000000000000..869e0ea8220b
--- /dev/null
+++ b/games-board/mt_gtk_client/files/mt_gtk_client-0.1.98-formatsecurity.patch
@@ -0,0 +1,11 @@
+--- src/player.c.old 2015-10-14 21:52:59.453971198 +0200
++++ src/player.c 2015-10-14 21:53:36.375289009 +0200
+@@ -52,7 +52,7 @@
+ {
+ player->nick[0] = g_string_new (config->gui_player_name->str);
+
+- g_printerr (player->nick[0]->str);
++ g_printerr ("%s", player->nick[0]->str);
+
+ gdk_threads_enter ();
+ gtk_statusbar_push (GTK_STATUSBAR (gui_statusbar), 0,
diff --git a/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild b/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild
index 191093914777..1b0657c7f9ff 100644
--- a/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild
+++ b/games-board/mt_gtk_client/mt_gtk_client-0.1.98.ebuild
@@ -3,7 +3,7 @@
# $Id$
EAPI=5
-inherit games
+inherit games eutils
DESCRIPTION="client for the french tarot game maitretarot"
HOMEPAGE="http://www.nongnu.org/maitretarot/"
@@ -23,6 +23,10 @@ DEPEND="dev-libs/glib:2
RDEPEND="${DEPEND}
dev-games/cardpics"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-formatsecurity.patch
+}
+
src_configure() {
egamesconf $(use_enable gnome gnome2)
}