summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gxmame/gxmame-0.35_beta2.ebuild22
1 files changed, 9 insertions, 13 deletions
diff --git a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
index 9f8c694f46d5..508f35a95123 100644
--- a/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
+++ b/games-emulation/gxmame/gxmame-0.35_beta2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
MY_P="${PN}-${PV/_beta/beta}"
@@ -27,13 +27,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-glib-single-include.patch
- epatch "${FILESDIR}"/${P}-ovflfix.patch
+ epatch \
+ "${FILESDIR}"/${P}-glib-single-include.patch \
+ "${FILESDIR}"/${P}-ovflfix.patch
sed -i \
-e "s:-O2 -fomit-frame-pointer -ffast-math:${CFLAGS}:" \
-e "s:-O2:${CFLAGS}:" \
- configure \
- || die "sed failed"
+ configure || die
sed -i \
-e 's:COPYING::' \
-e "s:^docdir = .*:docdir = /usr/share/doc/${PF}:" \
@@ -45,23 +45,19 @@ src_prepare() {
-e "s:^Graphicsdir = .*:Graphicsdir = /usr/share/applications:" \
-e "/DDATADIR/s:\$(datadir):/usr/share/pixmaps:" \
-e "/DPACKAGE_LOCALE_DIR/s:\$(datadir):/usr/share:" \
- Makefile.in html/Makefile.in src/Makefile.in po/Makefile.in.in \
- || die "sed failed"
- sed -i \
- -e 's/"gxmame"/""/' src/gui.c \
- || die "sed failed"
+ Makefile.in html/Makefile.in src/Makefile.in po/Makefile.in.in || die
+ sed -i -e 's/"gxmame"/""/' src/gui.c || die
}
src_configure() {
egamesconf \
- --disable-dependency-tracking \
--with-xmame-dir="${GAMES_DATADIR}"/xmame \
$(use_enable nls) \
$(use_enable joystick)
}
src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO" \
+ default
prepgamesdirs
}