summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild7
-rw-r--r--games-emulation/dosbox/dosbox-0.74_p20160629.ebuild7
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
index f622d980d347..d7fd016f2ca3 100644
--- a/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils flag-o-matic
+
+inherit autotools desktop flag-o-matic
PATCH=3989
GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b
@@ -31,7 +32,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
)
src_prepare() {
diff --git a/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
index 45b0b0fdb711..a7b41d8d34ea 100644
--- a/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils
+
+inherit autotools desktop
PATCH=3989
DESCRIPTION="DOS emulator"
@@ -27,7 +28,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
)
src_prepare() {
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index bceaab9e8150..786b1f786887 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools desktop flag-o-matic
+
GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
SRC_URI="glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
@@ -14,8 +16,6 @@ else
KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
fi
-inherit autotools eutils flag-o-matic
-
DESCRIPTION="DOS emulator"
HOMEPAGE="http://dosbox.sourceforge.net/"
@@ -37,7 +37,9 @@ if [[ ${PV} = 9999 ]]; then
S=${WORKDIR}/${PN}
fi
-PATCHES=( "${FILESDIR}/${PN}-0.74-gcc46.patch" )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.74-gcc46.patch
+)
src_prepare() {
use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff