summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/gargoyle')
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/games-engines/gargoyle/gargoyle-2011.1.ebuild b/games-engines/gargoyle/gargoyle-2011.1.ebuild
index 428fc301da11..0494b53bae62 100644
--- a/games-engines/gargoyle/gargoyle-2011.1.ebuild
+++ b/games-engines/gargoyle/gargoyle-2011.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -10,7 +10,7 @@
# don't apply. (Fonts are installed through dependencies instead.)
EAPI=5
-inherit eutils multiprocessing toolchain-funcs gnome2-utils games
+inherit eutils flag-o-matic multiprocessing toolchain-funcs gnome2-utils games
DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
HOMEPAGE="http://ccxvii.net/gargoyle/"
@@ -57,6 +57,7 @@ src_prepare() {
sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini || die
epatch "${FILESDIR}"/${P}-desktopfile.patch
+ append-cflags -std=gnu89 # build with gcc5 (bug #573378)
}
src_compile() {