summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/odamex')
-rw-r--r--games-engines/odamex/Manifest1
-rw-r--r--games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch79
-rw-r--r--games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch77
-rw-r--r--games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch59
-rw-r--r--games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch51
-rw-r--r--games-engines/odamex/odamex-0.6.4.ebuild103
6 files changed, 0 insertions, 370 deletions
diff --git a/games-engines/odamex/Manifest b/games-engines/odamex/Manifest
index 4bca1797b131..f7868f145e03 100644
--- a/games-engines/odamex/Manifest
+++ b/games-engines/odamex/Manifest
@@ -1,2 +1 @@
-DIST odamex-src-0.6.4.tar.bz2 8449818 SHA256 7832fed1e0cca992c746fd0f7e876b090c0f244f2d1d5230ffa3df8b33ce0f6a SHA512 0a917568cfc4bd4d9921cb82185cbbc318bce493bc66e489093e45401ec4c7596148778648e5078f13c50824470a040a995aa50c7956e2446c90920254c8129f WHIRLPOOL 9d95a9422ab382ccd5f4fc7d89f0558e30c604e18a33eec3bb074ae446258f030ec67d4738e1c517d89c9a4e09aea6e3a84651d7c8b1df9a88a26077c1b319b4
DIST odamex-src-0.7.0.tar.bz2 8435860 SHA256 d0306ddca3d5534672e6f0c547092d8f3f6f815686e4f6b21d6521afae1fd73b SHA512 410f3c2588e4d57006e5bb50eaa0f6c1a83cf197ce40daabb958667483eb6c85138206ac74b8aee64c4208c4360415ad16d1698534be5c7abec1493a0f91aa8b WHIRLPOOL 91ca8f658435f4503df8a2d5f52b1ef1cf34229373c4e1c3918b7eb919ae54e3a416618ce184d54c6ebc25bdfe6fea96f8933f98d859562b4972f89bd5c320ff
diff --git a/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch b/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
deleted file mode 100644
index 48205033d621..000000000000
--- a/games-engines/odamex/files/1-odamex-0.6.4-install-rules.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-commit 04fff802ee72c08d2e1730c6c5506fc2e708d5fe
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 31 03:34:29 2013 +0200
-
- BUILD: add unix install rules
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b77096a..f49a1e8 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -2,6 +2,8 @@
- project(Odamex)
- cmake_minimum_required(VERSION 2.8)
-
-+# cmake modules
-+include( GNUInstallDirs )
- set(PROJECT_VERSION 0.6.4)
- set(PROJECT_COPYRIGHT "2006-2013")
-
-@@ -64,3 +66,8 @@ add_subdirectory(odalaunch)
- if(NOT NO_AG-ODALAUNCH_TARGET)
- add_subdirectory(ag-odalaunch)
- endif()
-+
-+# global install rules
-+if(UNIX)
-+ install(FILES odamex.wad DESTINATION ${CMAKE_INSTALL_DATADIR})
-+endif()
-diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
-index 5dd5d43..1fde0ff 100644
---- a/client/CMakeLists.txt
-+++ b/client/CMakeLists.txt
-@@ -168,5 +168,8 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
- " )
- endif()
-
-+ # UNIX install rules
-+ elseif(UNIX)
-+ install( TARGETS odamex DESTINATION ${CMAKE_INSTALL_BINDIR} )
- endif()
- endif()
-diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
-index c1c3853..3e94b34 100644
---- a/master/CMakeLists.txt
-+++ b/master/CMakeLists.txt
-@@ -12,3 +12,8 @@ if(WIN32)
- elseif(SOLARIS)
- target_link_libraries(odamast socket nsl)
- endif()
-+
-+# install rules
-+if(UNIX)
-+ install( TARGETS odamast DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
-diff --git a/odalaunch/CMakeLists.txt b/odalaunch/CMakeLists.txt
-index ff9b6e3..d2d2171 100644
---- a/odalaunch/CMakeLists.txt
-+++ b/odalaunch/CMakeLists.txt
-@@ -61,3 +61,8 @@ if(wxWidgets_FOUND)
- )
- endif()
- endif()
-+
-+# install rules
-+if(UNIX)
-+ install( TARGETS odalaunch DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
-diff --git a/server/CMakeLists.txt b/server/CMakeLists.txt
-index 2284a8a..a079434 100644
---- a/server/CMakeLists.txt
-+++ b/server/CMakeLists.txt
-@@ -61,3 +61,7 @@ if(UNIX AND NOT APPLE)
- target_link_libraries(odasrv rt)
- endif()
-
-+# install rules
-+if(UNIX)
-+ install( TARGETS odasrv DESTINATION ${CMAKE_INSTALL_BINDIR} )
-+endif()
diff --git a/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch b/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
deleted file mode 100644
index de0f0784ca97..000000000000
--- a/games-engines/odamex/files/2-odamex-0.6.4-cmake-options.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-commit 7abf37ed186701f0170bded26df8cbb8a99a21e1
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 31 03:35:46 2013 +0200
-
- BUILD: add various cmake options
-
- to control building client/server/odalaunch
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index f49a1e8..ca01bba 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -3,7 +3,15 @@ project(Odamex)
- cmake_minimum_required(VERSION 2.8)
-
- # cmake modules
-+include( CMakeDependentOption )
- include( GNUInstallDirs )
-+
-+# options
-+option(BUILD_CLIENT "Build client target" 1)
-+option(BUILD_SERVER "Build server target" 1)
-+option(BUILD_MASTER "Build master server target" 1)
-+cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
-+cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
- set(PROJECT_VERSION 0.6.4)
- set(PROJECT_COPYRIGHT "2006-2013")
-
-@@ -56,10 +64,22 @@ endmacro(define_platform)
- set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
-
- # Subdirectories for individual projects
--add_subdirectory(client)
--add_subdirectory(server)
--add_subdirectory(master)
--add_subdirectory(odalaunch)
-+if(BUILD_CLIENT)
-+ add_subdirectory(client)
-+endif()
-+if(BUILD_SERVER)
-+ add_subdirectory(server)
-+endif()
-+if(BUILD_MASTER)
-+ add_subdirectory(master)
-+endif()
-+if(BUILD_ODALAUNCH)
-+ add_subdirectory(odalaunch)
-+endif()
-+
-+if(NOT BUILD_CLIENT AND NOT BUILD_SERVER AND NOT BUILD_MASTER)
-+ message(FATAL_ERROR "No target chosen, doing nothing.")
-+endif()
-
- # Disable the ag-odalaunch target completely: -DNO_AG-ODALAUNCH_TARGET
- # This is only really useful when setting up a universal build.
-diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
-index 1fde0ff..9f06fa6 100644
---- a/client/CMakeLists.txt
-+++ b/client/CMakeLists.txt
-@@ -48,7 +48,7 @@ endif()
-
- # PortMidi configuration
- find_package(PortMidi)
--if(PORTMIDI_FOUND)
-+if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
- include_directories(${PORTMIDI_INCLUDE_DIR})
- add_definitions(-DPORTMIDI)
- else()
-@@ -95,7 +95,7 @@ if(SDL_FOUND AND SDLMIXER_FOUND)
- target_link_libraries(odamex ${SDL_LIBRARY})
- target_link_libraries(odamex ${SDLMIXER_LIBRARY})
-
-- if(PORTMIDI_FOUND)
-+ if(PORTMIDI_FOUND AND ENABLE_PORTMIDI)
- target_link_libraries(odamex ${PORTMIDI_LIBRARIES})
- endif()
-
diff --git a/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch b/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
deleted file mode 100644
index 3eb6953cfe85..000000000000
--- a/games-engines/odamex/files/3-odamex-0.6.4-wad-search-path.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-commit 3a5209e2595e459a31c111f6040dbac347df1967
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 31 03:38:10 2013 +0200
-
- add odamex.wad install destination to wad search path
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index ca01bba..83a0e30 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -12,6 +12,16 @@ option(BUILD_SERVER "Build server target" 1)
- option(BUILD_MASTER "Build master server target" 1)
- cmake_dependent_option( BUILD_ODALAUNCH "Build odalaunch target" 1 BUILD_CLIENT 0 )
- cmake_dependent_option( ENABLE_PORTMIDI "Enable portmidi support" 1 BUILD_CLIENT 0 )
-+
-+configure_file (
-+ "${PROJECT_SOURCE_DIR}/config.h.in"
-+ "${PROJECT_BINARY_DIR}/config.h"
-+ )
-+
-+include_directories(
-+ ${PROJECT_BINARY_DIR}
-+)
-+
- set(PROJECT_VERSION 0.6.4)
- set(PROJECT_COPYRIGHT "2006-2013")
-
-diff --git a/common/d_main.cpp b/common/d_main.cpp
-index 010bdcb..6dc2e5f 100644
---- a/common/d_main.cpp
-+++ b/common/d_main.cpp
-@@ -23,6 +23,7 @@
- //-----------------------------------------------------------------------------
-
- #include "version.h"
-+#include "config.h"
-
- #include <sstream>
- #include <string>
-@@ -493,6 +494,7 @@ static std::string BaseFileSearch(std::string file, std::string ext = "", std::s
- D_AddSearchDir(dirs, getenv("DOOMWADDIR"), separator);
- D_AddSearchDir(dirs, getenv("DOOMWADPATH"), separator);
- D_AddSearchDir(dirs, getenv("HOME"), separator);
-+ D_AddSearchDir(dirs, CMAKE_WADDIR, separator);
-
- // [AM] Search additional paths based on platform
- D_AddPlatformSearchDirs(dirs);
-diff --git a/config.h.in b/config.h.in
-new file mode 100644
-index 0000000..e91b3a6
---- /dev/null
-+++ b/config.h.in
-@@ -0,0 +1,6 @@
-+#ifndef CONFIG_H
-+#define CONFIG_H
-+
-+#define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
-+
-+#endif
diff --git a/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch b/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
deleted file mode 100644
index 22244987d458..000000000000
--- a/games-engines/odamex/files/4-odamex-0.6.4-odalauncher-bin-path.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-commit a6c55c51dc251924be7eccf6637fc719a2b7ace0
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 31 03:38:24 2013 +0200
-
- use CMAKE_BINDIR as default bin patch in odalauncher
-
-diff --git a/config.h.in b/config.h.in
-index e91b3a6..7019a02 100644
---- a/config.h.in
-+++ b/config.h.in
-@@ -2,5 +2,6 @@
- #define CONFIG_H
-
- #define CMAKE_WADDIR "@CMAKE_INSTALL_DATADIR@"
-+#define CMAKE_BINDIR "@CMAKE_INSTALL_BINDIR@"
-
- #endif
-diff --git a/odalaunch/src/dlg_main.cpp b/odalaunch/src/dlg_main.cpp
-index 915b527..f01224a 100644
---- a/odalaunch/src/dlg_main.cpp
-+++ b/odalaunch/src/dlg_main.cpp
-@@ -27,6 +27,7 @@
- #include "str_utils.h"
-
- #include "md5.h"
-+#include "config.h"
-
- #include <wx/settings.h>
- #include <wx/menu.h>
-@@ -42,6 +43,7 @@
- #include <wx/process.h>
- #include <wx/toolbar.h>
- #include <wx/xrc/xmlres.h>
-+#include <wx/string.h>
- #include <wx/cmdline.h>
-
- #ifdef __WXMSW__
-@@ -200,10 +202,12 @@ dlgMain::dlgMain(wxWindow* parent, wxWindowID id)
- }
- #endif
-
-+ const char *cmake_bindir_str = CMAKE_BINDIR;
-+ wxString cmake_bindir = wxString::FromAscii(cmake_bindir_str);
- launchercfg_s.get_list_on_start = 1;
- launchercfg_s.show_blocked_servers = 0;
- launchercfg_s.wad_paths = wxGetCwd();
-- launchercfg_s.odamex_directory = wxGetCwd();
-+ launchercfg_s.odamex_directory = cmake_bindir;
-
- m_LstCtrlServers = XRCCTRL(*this, "Id_LstCtrlServers", LstOdaServerList);
- m_LstCtrlPlayers = XRCCTRL(*this, "Id_LstCtrlPlayers", LstOdaPlayerList);
diff --git a/games-engines/odamex/odamex-0.6.4.ebuild b/games-engines/odamex/odamex-0.6.4.ebuild
deleted file mode 100644
index f2e15ed1199f..000000000000
--- a/games-engines/odamex/odamex-0.6.4.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-WX_GTK_VER="2.8"
-inherit cmake-utils eutils gnome2-utils wxwidgets games
-
-MY_P=${PN}-src-${PV}
-DESCRIPTION="An online multiplayer, free software engine for Doom and Doom II"
-HOMEPAGE="http://odamex.net/"
-SRC_URI="mirror://sourceforge/${PN}/Odamex/${PV}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dedicated +odalaunch master portmidi server"
-
-RDEPEND="
- dedicated? ( >=net-libs/miniupnpc-1.8 )
- !dedicated? (
- >=media-libs/libsdl-1.2.9[X,sound,joystick,video]
- >=media-libs/sdl-mixer-1.2.6
- odalaunch? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
- portmidi? ( media-libs/portmidi )
- server? ( >=net-libs/miniupnpc-1.8 )
- )"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/1-${P}-install-rules.patch \
- "${FILESDIR}"/2-${P}-cmake-options.patch \
- "${FILESDIR}"/3-${P}-wad-search-path.patch \
- "${FILESDIR}"/4-${P}-odalauncher-bin-path.patch
-
- epatch_user
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_BINDIR="${GAMES_BINDIR}"
- -DCMAKE_INSTALL_DATADIR="${GAMES_DATADIR}"/${PN}
- $(cmake-utils_use_build master MASTER)
- )
-
- if use dedicated ; then
- mycmakeargs+=(
- -DBUILD_CLIENT=OFF
- -DBUILD_ODALAUNCH=OFF
- -DBUILD_SERVER=ON
- -DENABLE_PORTMIDI=OFF
- )
- else
- mycmakeargs+=(
- -DBUILD_CLIENT=ON
- $(cmake-utils_use_build odalaunch ODALAUNCH)
- $(cmake-utils_use_build server SERVER)
- $(cmake-utils_use_enable portmidi PORTMIDI)
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-
- if ! use dedicated ; then
- newicon -s 128 "${S}/media/icon_${PN}_128.png" "${PN}.png"
- make_desktop_entry ${PN}
-
- if use odalaunch ; then
- newicon -s 128 "${S}/media/icon_odalaunch_128.png" "odalaunch.png"
- make_desktop_entry odalaunch "Odamex Launcher" odalaunch
- fi
- fi
-
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- games_pkg_postinst
- einfo
- elog "This is just the engine, you will need doom resource files in order to play."
- elog "Check: http://odamex.net/wiki/FAQ#What_data_files_are_required.3F"
- einfo
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}