summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/scummvm')
-rw-r--r--games-engines/scummvm/Manifest1
-rw-r--r--games-engines/scummvm/files/scummvm-2.1.0-tts_pthread_link.patch22
-rw-r--r--games-engines/scummvm/metadata.xml1
-rw-r--r--games-engines/scummvm/scummvm-2.1.0.ebuild109
4 files changed, 133 insertions, 0 deletions
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index e3b863b34060..eafca9329bc7 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1 +1,2 @@
DIST scummvm-2.0.0.tar.xz 21291656 BLAKE2B 303aa4254d1c940ce6d65d192f2678a033015f1b85e38c62902aa8fac05a1ff33fd7e3fe9de47825cd0cf72076027adb21c72a63a38349f9ee8f63566f3db948 SHA512 5f4c11145c5dfcc7ae95d5c0e5ac9e938912cc5060b9d5fdfcb699a745755b31412e44199e487ad388ca5e091afc3366f874610adb44d440f336e26d6cd4812c
+DIST scummvm-2.1.0.tar.xz 27188916 BLAKE2B b808ff335e5b25c58c8caebfe660b4c2938dcb6eada0aa5b31777b97ff2fb7cb3732d516fc4d981ab1bee16876d62f634f69517158c7c233e11cc22575b15c09 SHA512 9a03cf207660aa49e49f53e1df10b774b7c9711dffd527e00518015e7e7057f25538a7dd89e248e9237434cf08a9f7ea6b215805fb65a770fb20596f5e713218
diff --git a/games-engines/scummvm/files/scummvm-2.1.0-tts_pthread_link.patch b/games-engines/scummvm/files/scummvm-2.1.0-tts_pthread_link.patch
new file mode 100644
index 000000000000..70440be0e13a
--- /dev/null
+++ b/games-engines/scummvm/files/scummvm-2.1.0-tts_pthread_link.patch
@@ -0,0 +1,22 @@
+From 26c09be3a091e47419ba2629c5f2a346ad6a5543 Mon Sep 17 00:00:00 2001
+From: Christian Krause <chkr@plauener.de>
+Date: Wed, 16 Oct 2019 22:41:27 +0200
+Subject: [PATCH] TTS: Link libpthread explicitly on Linux platform
+
+---
+ configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 0adf0bb7bad..dbfe336e6d0 100755
+--- a/configure
++++ b/configure
+@@ -5504,7 +5504,7 @@ else
+ echo "linux"
+ _tts=yes
+ define_in_config_if_yes $_tts 'USE_SPEECH_DISPATCHER'
+- append_var LIBS '-lspeechd'
++ append_var LIBS '-lspeechd -lpthread'
+ ;;
+ mingw*)
+ echo "win32"
diff --git a/games-engines/scummvm/metadata.xml b/games-engines/scummvm/metadata.xml
index 3f7ace82af07..e71c4a5e17bb 100644
--- a/games-engines/scummvm/metadata.xml
+++ b/games-engines/scummvm/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="fluidsynth">compile with support for fluidsynth</flag>
<flag name="mpeg2">enable mpeg2 codec for cutscenes</flag>
+ <flag name="speech">enable text-to-speech support through <pkg>app-accessibility/speech-dispatcher</pkg></flag>
<flag name="unsupported">enable unsupported and/or broken game engines (you're on your own)</flag>
</use>
<upstream>
diff --git a/games-engines/scummvm/scummvm-2.1.0.ebuild b/games-engines/scummvm/scummvm-2.1.0.ebuild
new file mode 100644
index 000000000000..f278a9a54712
--- /dev/null
+++ b/games-engines/scummvm/scummvm-2.1.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="https://www.scummvm.org/"
+SRC_URI="https://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="a52 aac alsa debug flac fluidsynth jpeg lua mpeg2 mp3 opengl png speech theora truetype unsupported vorbis zlib"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.0[sound,joystick,video]
+ media-libs/sdl2-net
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )
+ jpeg? ( virtual/jpeg:0 )
+ mp3? ( media-libs/libmad )
+ mpeg2? ( media-libs/libmpeg2 )
+ opengl? ( virtual/opengl )
+ png? ( media-libs/libpng:0 )
+ speech? ( app-accessibility/speech-dispatcher )
+ truetype? ( media-libs/freetype:2 )
+ theora? ( media-libs/libtheora )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ truetype? ( virtual/pkgconfig )
+ x86? ( dev-lang/nasm )
+"
+
+S="${WORKDIR}/${P/_/}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-tts_pthread_link.patch"
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ use x86 && append-ldflags -Wl,-z,noexecstack
+
+ local myconf=(
+ --backend=sdl
+ --host=${CHOST}
+ --enable-verbose-build
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --opengl-mode=$(usex opengl auto none)
+ $(use_enable a52)
+ $(use_enable aac faad)
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable !debug release-mode)
+ $(use_enable flac)
+ $(usex fluidsynth '' --disable-fluidsynth)
+ $(use_enable jpeg)
+ $(use_enable lua)
+ $(use_enable mp3 mad)
+ $(use_enable mpeg2)
+ $(use_enable png)
+ $(use_enable speech tts)
+ $(use_enable theora theoradec)
+ $(use_enable truetype freetype2)
+ $(usex unsupported --enable-all-engines '')
+ $(use_enable vorbis)
+ $(use_enable zlib)
+ $(use_enable x86 nasm)
+ )
+ echo "configure ${myconf[@]}"
+ # NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
+ SDL_CONFIG="sdl2-config" \
+ ./configure "${myconf[@]}" "${EXTRA_ECONF}" || die
+}
+
+src_compile() {
+ emake AR="$(tc-getAR) cru" RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ default
+ doicon -s scalable icons/scummvm.svg
+}