summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/love/Manifest2
-rw-r--r--games-engines/love/love-0.10.2.ebuild75
-rw-r--r--games-engines/love/love-0.8.0-r1.ebuild37
-rw-r--r--games-engines/love/love-11.1.ebuild74
4 files changed, 0 insertions, 188 deletions
diff --git a/games-engines/love/Manifest b/games-engines/love/Manifest
index 4e9a4259ad12..dc1d7facea60 100644
--- a/games-engines/love/Manifest
+++ b/games-engines/love/Manifest
@@ -1,5 +1,3 @@
-DIST love-0.10.2-linux-src.tar.gz 1698376 BLAKE2B aac7baaa51b4def09d73bcf6cbc3c98835c4b12f2608d229a8aeb3eb39a82285964f7cef0063c461bdae6e4431adf4f48e83be499a76ce463f941c7778d4a229 SHA512 81c0bb5a454ed9abc692784f155933288a2bd5ba5ffb919c7709584e7e8d68fca10b5ea1e3a386def46b18f071b217ffbc2914a8ea08424226f0580020fce076
DIST love-0.7.2-linux-src.tar.gz 900209 BLAKE2B abd0db98d210c5523d3b5a75c30bcfa2fc9d7760c7642d08dda28690ab72ddf8a0c7b60793cd7b0f902a8e3fcf2750748c75caf29638a7455572d84683be7820 SHA512 cbca1d7e3425d1ecbdae019212dfa2814d8ac3bad1faedd4b052cf3e89b5bf2fac6e422283628e4c125858c9db050dee2129476d1a73ec44ffe8a4704f170f61
DIST love-0.8.0-linux-src.tar.gz 1027356 BLAKE2B bfbc2f9a3d5c3beffb4790a69716416815534c3b390b1554722eceaec57a7530377c06c15c6551aa972b33176bccdadfc8ad12bc186ceda201527bd9f8286d6f SHA512 6a0e28d102b950d3dddf7101996fe0ad04dfd7d4ec5e58797b41ef3382b60e74f90c6e707f882cf43cc0c5cc98703857eefc6418e6a6fd34e88f8019143f55a4
-DIST love-11.1-linux-src.tar.gz 2733030 BLAKE2B 28b8bb4ea65fada095d725d438fa13a3d1210b2ab6e48932d1e62d342711e0d38ab0f84380fcb7e1b03b0bca6ab112ed66e848bb63aef6fde02605ba819209ae SHA512 f4df860508b75e4bb7c0ee8a2ee4406a7c8f3ce65cdbca9ed8a0cd90df81507ba7ec9a9d45279488047cc16b6e51940edff54e7a34de63bf852dbec5115b4c03
DIST love-11.3-linux-src.tar.gz 2898851 BLAKE2B ae854dbe1f98fa2adaf118ac01b7519f87cbf684dff45622e0de6503a514bc6336c469b08a6c19ae55f7a0d65063bebffe0dc1d0a72483a9032902469c1c643f SHA512 d02900bbad658da7127bdbc52ceb8282a725b32d6a17fc51962327411be94f81b2c871d21b3c4bd8492a4ca355c3cfb1f04a7fe010d6c69ae35c7c5d64579e1b
diff --git a/games-engines/love/love-0.10.2.ebuild b/games-engines/love/love-0.10.2.ebuild
deleted file mode 100644
index 9ac920cc9cd8..000000000000
--- a/games-engines/love/love-0.10.2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2-utils xdg-utils
-
-if [[ ${PV} == 9999* ]]; then
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
-LICENSE="ZLIB"
-SLOT="0.10"
-IUSE="+luajit"
-
-RDEPEND="sys-libs/zlib
- dev-games/physfs
- !luajit? ( dev-lang/lua:0[deprecated] )
- luajit? ( dev-lang/luajit:2 )
- media-libs/freetype
- media-libs/libmodplug
- media-libs/libsdl2[joystick,opengl]
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/openal
- media-sound/mpg123
- virtual/opengl"
-DEPEND="${RDEPEND}"
-
-DOCS=( "readme.md" "changes.txt" )
-
-src_prepare() {
- default
- if [[ ${PV} == 9999* ]]; then
- ./platform/unix/automagic || die
- fi
-}
-
-src_configure() {
- econf --with-lua=$(usex luajit luajit lua)
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
- if [[ ${SLOT} != 0 ]]
- then
- mv "${ED}/usr/bin/${PN}" "${ED}/usr/bin/${PN}-${SLOT}" || die
- mv "${ED}"/usr/share/applications/love{,"-$SLOT"}.desktop || die
- sed -i -e "/^Name=/s/$/ ($SLOT)/" -e "s|/usr/bin/love|/usr/bin/love-$SLOT|" "${ED}/usr/share/applications/love-$SLOT.desktop" || die
- rm -r "${ED}"/usr/{lib64/liblove.so,share/{mime/,pixmaps/,icons/,man/}} || die
- fi
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
diff --git a/games-engines/love/love-0.8.0-r1.ebuild b/games-engines/love/love-0.8.0-r1.ebuild
deleted file mode 100644
index 4545622486fc..000000000000
--- a/games-engines/love/love-0.8.0-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
-KEYWORDS="~amd64 ~arm ~x86"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-games/physfs
- dev-lang/lua:0[deprecated]
- media-libs/devil[mng,png,tiff]
- media-libs/freetype:2
- media-libs/libmodplug
- media-libs/libsdl[joystick,opengl,video]
- media-libs/libvorbis
- media-libs/openal
- media-sound/mpg123
- virtual/opengl
-"
-DEPEND="${RDEPEND}
- media-libs/libmng:0
- media-libs/tiff:0
-"
-
-PATCHES=( "${FILESDIR}"/${P}-freetype2.patch )
-
-src_install() {
- DOCS="readme.md changes.txt" \
- default
-}
diff --git a/games-engines/love/love-11.1.ebuild b/games-engines/love/love-11.1.ebuild
deleted file mode 100644
index 8f965557a423..000000000000
--- a/games-engines/love/love-11.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit gnome2-utils xdg-utils
-
-if [[ ${PV} == 9999* ]]; then
- inherit mercurial
- EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="+luajit"
-
-RDEPEND="sys-libs/zlib
- !luajit? ( dev-lang/lua:0[deprecated] )
- luajit? ( dev-lang/luajit:2 )
- media-libs/freetype
- media-libs/libmodplug
- media-libs/libsdl2[joystick,opengl]
- media-libs/libogg
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/openal
- media-sound/mpg123
- virtual/opengl"
-DEPEND="${RDEPEND}"
-
-DOCS=( "readme.md" "changes.txt" )
-
-src_prepare() {
- default
- if [[ ${PV} == 9999* ]]; then
- ./platform/unix/automagic || die
- fi
-}
-
-src_configure() {
- econf --with-lua=$(usex luajit luajit lua)
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
- if [[ ${SLOT} != 0 ]]
- then
- mv "${ED}/usr/bin/${PN}" "${ED}/usr/bin/${PN}-${SLOT}" || die
- mv "${ED}"/usr/share/applications/love{,"-$SLOT"}.desktop || die
- sed -i -e "/^Name=/s/$/ ($SLOT)/" -e "s|/usr/bin/love|/usr/bin/love-$SLOT|" "${ED}/usr/share/applications/love-$SLOT.desktop" || die
- rm -r "${ED}"/usr/{lib64/liblove.so,share/{mime/,pixmaps/,icons/,man/}} || die
- fi
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
-}