summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/love/love-0.8.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-engines/love/love-0.8.0-r1.ebuild b/games-engines/love/love-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..4545622486fc
--- /dev/null
+++ b/games-engines/love/love-0.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A framework for 2D games in Lua"
+HOMEPAGE="http://love2d.org/"
+SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
+KEYWORDS="~amd64 ~arm ~x86"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-games/physfs
+ dev-lang/lua:0[deprecated]
+ media-libs/devil[mng,png,tiff]
+ media-libs/freetype:2
+ media-libs/libmodplug
+ media-libs/libsdl[joystick,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-sound/mpg123
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ media-libs/libmng:0
+ media-libs/tiff:0
+"
+
+PATCHES=( "${FILESDIR}"/${P}-freetype2.patch )
+
+src_install() {
+ DOCS="readme.md changes.txt" \
+ default
+}