summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/stone-soup/files/rltiles-ldflags-libs.patch45
-rw-r--r--games-roguelike/stone-soup/metadata.xml4
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.22.0.ebuild4
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.23.0.ebuild2
4 files changed, 48 insertions, 7 deletions
diff --git a/games-roguelike/stone-soup/files/rltiles-ldflags-libs.patch b/games-roguelike/stone-soup/files/rltiles-ldflags-libs.patch
new file mode 100644
index 000000000000..a2948b23619c
--- /dev/null
+++ b/games-roguelike/stone-soup/files/rltiles-ldflags-libs.patch
@@ -0,0 +1,45 @@
+--- a/rltiles/Makefile
++++ b/rltiles/Makefile
+@@ -1,7 +1,7 @@
+ uname_S := $(shell uname -s)
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lmingw32
++LIBS += -lmingw32
+ endif
+
+ # Note: since generation of tiles is done on the host, we don't care about
+@@ -29,7 +29,7 @@
+ endif
+
+ CFLAGS += $(PNG_INCLUDE)
+- LDFLAGS += $(PNG_LIB)
++ LIBS += $(PNG_LIB)
+
+ CFLAGS += -DUSE_TILE
+ endif
+@@ -39,13 +39,13 @@
+ endif
+
+ ifneq (,$(findstring MINGW,$(uname_S)))
+-LDFLAGS += -lgdi32 -lwinmm -lole32 -loleaut32 -limm32 -lshell32 -lversion -luuid
++LIBS += -lgdi32 -lwinmm -lole32 -loleaut32 -limm32 -lshell32 -lversion -luuid
+ endif
+ ifeq ($(uname_S),Darwin)
+-LDFLAGS += -framework AppKit -framework AudioUnit -framework CoreAudio -framework ForceFeedback -framework Carbon -framework IOKit -framework OpenGL
++LIBS += -framework AppKit -framework AudioUnit -framework CoreAudio -framework ForceFeedback -framework Carbon -framework IOKit -framework OpenGL
+ endif
+ ifeq ($(uname_S),Linux)
+-LDFLAGS += -ldl -lpthread
++LIBS += -ldl -lpthread
+ endif
+
+ # Attempt to use a full compiler name, to make
+@@ -134,6 +134,6 @@
+ $(QUIET_HOSTCXX)$(HOSTCXX) $(CFLAGS) -MMD -c $< -o $@
+
+ $(TILEGEN): $(OBJECTS)
+- $(QUIET_HOSTLINK)$(HOSTCXX) $(CFLAGS) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(QUIET_HOSTLINK)$(HOSTCXX) $(CFLAGS) $(OBJECTS) -o $@ $(LDFLAGS) $(LIBS)
+
+ .PHONY: all clean distclean
diff --git a/games-roguelike/stone-soup/metadata.xml b/games-roguelike/stone-soup/metadata.xml
index ec38a399560c..68e84b34cc48 100644
--- a/games-roguelike/stone-soup/metadata.xml
+++ b/games-roguelike/stone-soup/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>stasibear@gentoo.org</email>
- <name>Erik Mackdanz</name>
- </maintainer>
<maintainer type="project">
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
diff --git a/games-roguelike/stone-soup/stone-soup-0.22.0.ebuild b/games-roguelike/stone-soup/stone-soup-0.22.0.ebuild
index 742c2c56bd9e..92ce93f41ce3 100644
--- a/games-roguelike/stone-soup/stone-soup-0.22.0.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.22.0.ebuild
@@ -23,7 +23,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug luajit ncurses test +tiles"
# test is broken
# see https://crawl.develz.org/mantis/view.php?id=6121
@@ -56,7 +56,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/source
S_TEST=${WORKDIR}/${MY_P}_test/source
PATCHES=(
- "${FILESDIR}"/${PN}-0.20.1-rltiles-ldflags-libs.patch
+ "${FILESDIR}"/rltiles-ldflags-libs.patch
)
pkg_setup() {
diff --git a/games-roguelike/stone-soup/stone-soup-0.23.0.ebuild b/games-roguelike/stone-soup/stone-soup-0.23.0.ebuild
index 876c7001d735..92ce93f41ce3 100644
--- a/games-roguelike/stone-soup/stone-soup-0.23.0.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.23.0.ebuild
@@ -56,7 +56,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}/source
S_TEST=${WORKDIR}/${MY_P}_test/source
PATCHES=(
- "${FILESDIR}"/${PN}-0.20.1-rltiles-ldflags-libs.patch
+ "${FILESDIR}"/rltiles-ldflags-libs.patch
)
pkg_setup() {