summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/gwiz/files/gwiz-0.8-buffer.patch8
-rw-r--r--games-rpg/gwiz/gwiz-0.8-r1.ebuild37
2 files changed, 41 insertions, 4 deletions
diff --git a/games-rpg/gwiz/files/gwiz-0.8-buffer.patch b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
index 7c9eb02cf503..44ee9aec15fb 100644
--- a/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
+++ b/games-rpg/gwiz/files/gwiz-0.8-buffer.patch
@@ -1,5 +1,5 @@
---- src/equip.c.orig
-+++ src/equip.c
+--- a/src/equip.c
++++ b/src/equip.c
@@ -120,7 +120,7 @@
return (i);
@@ -9,8 +9,8 @@
if (pawn->item[i].usage & USAGE_EQUIPPABLE)
return (i);
return (-1);
---- src/shop.c.orig
-+++ src/shop.c
+--- a/src/shop.c
++++ b/src/shop.c
@@ -290,8 +290,7 @@
SDL_BlitSurface (name, NULL, area, &dest);
diff --git a/games-rpg/gwiz/gwiz-0.8-r1.ebuild b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
new file mode 100644
index 000000000000..01b725cbda58
--- /dev/null
+++ b/games-rpg/gwiz/gwiz-0.8-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="clone of old-school Wizardry(tm) games by SirTech"
+HOMEPAGE="http://icculus.org/gwiz/"
+SRC_URI="http://icculus.org/gwiz/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2.3[joystick,video]
+ >=media-libs/sdl-image-1.2.1-r1[png]
+ >=media-libs/sdl-ttf-2.0.4"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buffer.patch
+)
+
+src_prepare() {
+ default
+
+ append-cflags -std=gnu89 # build with gcc5 (bug #572532)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README doc/HOWTO-PLAY" \
+ default
+ newicon pixmaps/gwiz_icon.xpm ${PN}.xpm
+ make_desktop_entry gwiz Gwiz
+}