summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crashtest/crashtest-1.1-r1.ebuild')
-rw-r--r--games-simulation/crashtest/crashtest-1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-simulation/crashtest/crashtest-1.1-r1.ebuild b/games-simulation/crashtest/crashtest-1.1-r1.ebuild
new file mode 100644
index 000000000000..6c3b1e2ee848
--- /dev/null
+++ b/games-simulation/crashtest/crashtest-1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Educational car crash simulator"
+HOMEPAGE="http://www.stolk.org/crashtest/"
+SRC_URI="http://www.stolk.org/crashtest/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-games/ode
+ media-libs/alsa-lib
+ media-libs/freeglut
+ x11-libs/fltk:1[opengl]
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ >=media-libs/plib-1.8.4"
+
+S=${WORKDIR}/${P}/src-${PN}
+
+PATCHES=(
+ "${FILESDIR}/${P}"-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ -e "s:@GENTOO_BINDIR@:/usr/bin:" \
+ Makefile ${PN}.cxx || die
+ append-cppflags -DHAVE_ISNANF
+}
+
+src_install() {
+ default
+ make_desktop_entry ${PN} Crashtest
+}