summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/crashtest/crashtest-1.1-r3.ebuild')
-rw-r--r--games-simulation/crashtest/crashtest-1.1-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-simulation/crashtest/crashtest-1.1-r3.ebuild b/games-simulation/crashtest/crashtest-1.1-r3.ebuild
new file mode 100644
index 000000000000..9157646d6f34
--- /dev/null
+++ b/games-simulation/crashtest/crashtest-1.1-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="Educational car crash simulator"
+HOMEPAGE="https://www.stolk.org/crashtest/"
+SRC_URI="https://www.stolk.org/crashtest/${P}.tar.gz"
+S="${WORKDIR}/${P}/src-${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-games/ode:=
+ media-libs/freeglut
+ media-libs/plib
+ virtual/glu
+ virtual/opengl
+ x11-libs/fltk:1=[opengl]"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ sed -e "s|@GENTOO_DATADIR@|${EPREFIX}/usr/share/${PN}|" \
+ -e "s|@GENTOO_BINDIR@|${EPREFIX}/usr/bin|" \
+ -i Makefile ${PN}.cxx || die
+
+ tc-export CXX
+}
+
+src_install() {
+ default
+
+ make_desktop_entry ${PN} Crashtest applications-games
+}