summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/flightgear/flightgear-9999.ebuild')
-rw-r--r--games-simulation/flightgear/flightgear-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/games-simulation/flightgear/flightgear-9999.ebuild b/games-simulation/flightgear/flightgear-9999.ebuild
index ce6c889aeb77..fcfdb4a0c9e2 100644
--- a/games-simulation/flightgear/flightgear-9999.ebuild
+++ b/games-simulation/flightgear/flightgear-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils bash-completion-r1 toolchain-funcs git-r3
+inherit cmake bash-completion-r1 toolchain-funcs git-r3
DESCRIPTION="Open Source Flight Simulator"
HOMEPAGE="https://www.flightgear.org/"
@@ -65,7 +65,9 @@ RDEPEND="${COMMON_DEPEND}
~games-simulation/${PN}-data-${PV}
"
-PATCHES=("${FILESDIR}/${PN}-2018.3.2-cmake.patch")
+PATCHES=(
+ "${FILESDIR}/${PN}-2020.1.2-cmake.patch"
+)
DOCS=(AUTHORS ChangeLog NEWS README Thanks)
@@ -75,6 +77,7 @@ pkg_pretend() {
src_configure() {
local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
-DENABLE_AUTOTESTING=OFF
-DENABLE_COMPOSITOR=OFF
-DENABLE_FGCOM=$(usex utils)
@@ -96,6 +99,7 @@ src_configure() {
-DENABLE_SIMD=OFF # see CPU_FLAGS
-DENABLE_SIMD_CODE=$(usex cpu_flags_x86_sse2)
-DENABLE_STGMERGE=ON
+ -DENABLE_SWIFT=OFF # swift pilot client not packaged yet
-DENABLE_TERRASYNC=$(usex utils)
-DENABLE_TRAFFIC=$(usex utils)
-DENABLE_UIUC_MODEL=ON
@@ -130,11 +134,11 @@ src_configure() {
mycmakeargs+=(-DENABLE_FGQCANVAS=OFF)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# Install bash completion (TODO zsh)
# Uncomment below when scripts stops writing files...