summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/gl117/gl117-1.3.2-r1.ebuild')
-rw-r--r--games-simulation/gl117/gl117-1.3.2-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-simulation/gl117/gl117-1.3.2-r1.ebuild b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f20c371d11a9
--- /dev/null
+++ b/games-simulation/gl117/gl117-1.3.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="gl-117-${PV}-src"
+DESCRIPTION="An action flight simulator"
+HOMEPAGE="http://www.heptargon.de/gl-117/gl-117.html"
+SRC_URI="mirror://sourceforge/gl-117/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/freeglut
+ media-libs/libsdl[sound,joystick,opengl,video]
+ media-libs/sdl-mixer[mod]
+ virtual/glu
+ virtual/opengl"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mode.patch
+)
+
+src_install() {
+ DOCS="doc/gl-117.pdf AUTHORS ChangeLog FAQ NEWS README" \
+ default
+ newicon doc/src/falcon.jpg ${PN}.jpg
+ make_desktop_entry gl-117 GL-117 /usr/share/pixmaps/${PN}.jpg
+ doman doc/gl-117.6
+}