summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/qct')
-rw-r--r--games-simulation/qct/Manifest1
-rw-r--r--games-simulation/qct/files/qct-0.7-constant.patch21
-rw-r--r--games-simulation/qct/metadata.xml5
-rw-r--r--games-simulation/qct/qct-0.7-r1.ebuild49
4 files changed, 76 insertions, 0 deletions
diff --git a/games-simulation/qct/Manifest b/games-simulation/qct/Manifest
new file mode 100644
index 000000000000..a16b1be45d10
--- /dev/null
+++ b/games-simulation/qct/Manifest
@@ -0,0 +1 @@
+DIST qct-0.7.tar.gz 98126 SHA256 d24d72c594e0af188876622aa2f9ce46e5e288bb66826aedb3ee3244fe8dd87b SHA512 89784607be3420f62ee1c94610f0df1e2ef57e237aa24ca2bf6583c17470ded91e8b5eff4171d93471a35c99951a98721eba2e9facb0757461c4343fbffe8bac WHIRLPOOL 21f27e3590edecbcdeb40a3dcc0c72a2cfc7413d0f27f508387590429b3920344f5fc581b6cecc671fa4e4382ff231cf4e13a29da754a986685216d782d07faa
diff --git a/games-simulation/qct/files/qct-0.7-constant.patch b/games-simulation/qct/files/qct-0.7-constant.patch
new file mode 100644
index 000000000000..43a01ea1a4a9
--- /dev/null
+++ b/games-simulation/qct/files/qct-0.7-constant.patch
@@ -0,0 +1,21 @@
+Fix traceback from using wrong name.
+
+Patch by Peter `MathFox' Roozemaal.
+
+http://bugs.gentoo.org/97762
+http://sourceforge.net/tracker/index.php?func=detail&aid=801329&group_id=74836&atid=542163
+
+--- qct/specializations.py
++++ qct/specializations.py
+@@ -131,9 +131,9 @@
+ mods = self.getModsFor('incomeMod', employer)
+ if resident:
+ if resident.job == trainer:
+- return prospect.level * INCOMEMULT * mods
++ return prospect.level * constants.INCOMEMULT * mods
+ else:
+- return prospect.level * INCOMEMULT / 2 * mods
++ return prospect.level * constants.INCOMEMULT / 2 * mods
+ else:
+ return 0
+
diff --git a/games-simulation/qct/metadata.xml b/games-simulation/qct/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-simulation/qct/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-simulation/qct/qct-0.7-r1.ebuild b/games-simulation/qct/qct-0.7-r1.ebuild
new file mode 100644
index 000000000000..5a48f6f181c0
--- /dev/null
+++ b/games-simulation/qct/qct-0.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+DESCRIPTION="Quiet Console Town puts you in the place of the mayor of a budding new console RPG city"
+HOMEPAGE="http://packages.gentoo.org/package/games-simulation/qct"
+SRC_URI="http://www.sourcefiles.org/Games/Role_Play/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=dev-python/pygame-1.5.5[${PYTHON_USEDEP}]"
+RDEPEND=${RDEPEND}
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-constant.patch
+ python_fix_shebang .
+}
+
+src_install() {
+ # Ug. Someone fix this to install in $(games_get_libdir)/${PN} instead
+ local destdir="${GAMES_DATADIR}/${PN}"
+ insinto "${destdir}"
+ exeinto "${destdir}"
+
+ dodoc README
+ doins *.py *.png
+ doexe qct.py
+
+ python_optimize "${D}${GAMES_DATADIR}/${PN}"
+
+ games_make_wrapper qct "./qct.py" "${destdir}"
+
+ prepgamesdirs
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}