summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/gracer')
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-giflib.patch14
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-warnings.patch21
-rw-r--r--games-sports/gracer/gracer-0.1.5.ebuild4
3 files changed, 38 insertions, 1 deletions
diff --git a/games-sports/gracer/files/gracer-0.1.5-giflib.patch b/games-sports/gracer/files/gracer-0.1.5-giflib.patch
new file mode 100644
index 000000000000..2d62b8c2082f
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-giflib.patch
@@ -0,0 +1,14 @@
+--- gracer-0.1.5.orig/common/gr_texture.c
++++ gracer-0.1.5/common/gr_texture.c
+@@ -274,7 +274,11 @@
+ int index;
+ int width, height;
+
++#if (GIFLIB_MAJOR >= 5&& !(GIFLIB_MAJOR == 5 && GIFLIB_MINOR == 0))
++ file = DGifOpenFileName (filename, &i);
++#else
+ file = DGifOpenFileName (filename);
++#endif
+ if (!file)
+ return -1;
+
diff --git a/games-sports/gracer/files/gracer-0.1.5-warnings.patch b/games-sports/gracer/files/gracer-0.1.5-warnings.patch
new file mode 100644
index 000000000000..5886ef763f3f
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-warnings.patch
@@ -0,0 +1,21 @@
+--- gracer-0.1.5.orig/src/glbind.c
++++ gracer-0.1.5/src/glbind.c
+@@ -142,7 +142,7 @@
+ return NULL;
+
+ entry = Tcl_FindHashEntry (&cache_hash, key);
+- if (&entry)
++ if (!entry)
+ return NULL;
+
+ return Tcl_GetHashValue (entry);
+--- gracer-0.1.5.orig/src/joystick.c
++++ gracer-0.1.5/src/joystick.c
+@@ -20,6 +20,7 @@
+ */
+
+ #include <unistd.h>
++#include <string.h>
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/games-sports/gracer/gracer-0.1.5.ebuild b/games-sports/gracer/gracer-0.1.5.ebuild
index 46a3f6718829..4fa9e7a42205 100644
--- a/games-sports/gracer/gracer-0.1.5.ebuild
+++ b/games-sports/gracer/gracer-0.1.5.ebuild
@@ -34,7 +34,9 @@ src_prepare() {
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}"/${P}-as-needed.patch \
"${FILESDIR}"/${P}-libpng14.patch \
- "${FILESDIR}"/${P}-png15.patch
+ "${FILESDIR}"/${P}-png15.patch \
+ "${FILESDIR}"/${P}-giflib.patch \
+ "${FILESDIR}"/${P}-warnings.patch
}
src_configure() {