summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch')
-rw-r--r--games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch101
1 files changed, 0 insertions, 101 deletions
diff --git a/games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch
deleted file mode 100644
index 5c48ec82ba5b..000000000000
--- a/games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Sun Jun 24 18:32:38 UTC 2012
-Subject: build system
-
-* respect flags
-* disable debug build of spidermonkey
-
---- libraries/source/fcollada/src/Makefile
-+++ libraries/source/fcollada/src/Makefile
-@@ -9,9 +9,9 @@
-
- CXX ?= g++
- CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
--CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
--CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
--CXXFLAGS_TEST := -O0 -g -D_DEBUG
-+CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
-+CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
-+CXXFLAGS_TEST := -D_DEBUG
- LIBS += `pkg-config libxml-2.0 --libs`
- INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
- INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
---- build/premake/premake4/src/tools/gcc.lua
-+++ build/premake/premake4/src/tools/gcc.lua
-@@ -136,8 +136,6 @@
- if not cfg.flags.Symbols then
- if cfg.system == "macosx" then
- table.insert(result, "-Wl,-x")
-- else
-- table.insert(result, "-s")
- end
- end
-
---- build/premake/premake4/build/gmake.unix/Premake4.make
-+++ build/premake/premake4/build/gmake.unix/Premake4.make
-@@ -26,9 +26,9 @@
- DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -Os
-- CXXFLAGS += $(CPPFLAGS) -Wall -Os
-- LDFLAGS += -s -rdynamic
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
-+ LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
- LDDEPS +=
-@@ -48,8 +48,8 @@
- DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
- INCLUDES += -I../../src/host/lua-5.1.4/src
- CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
-- CFLAGS += $(CPPFLAGS) -Wall -g
-- CXXFLAGS += $(CPPFLAGS) -Wall -g
-+ CFLAGS += $(CPPFLAGS) -Wall
-+ CXXFLAGS += $(CPPFLAGS) -Wall
- LDFLAGS += -rdynamic
- LIBS += -lm -ldl
- RESFLAGS += $(DEFINES) $(INCLUDES)
-@@ -302,4 +302,4 @@
- $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"
-
- -include $(OBJECTS:%.o=%.d)
---include $(GCH:%.h.gch=%.h.d)
-\ No newline at end of file
-+-include $(GCH:%.h.gch=%.h.d)
---- libraries/source/spidermonkey/build.sh
-+++ libraries/source/spidermonkey/build.sh
-@@ -92,19 +92,7 @@
- cd mozjs31/js/src
-
- # Clean up data generated by previous builds that could cause problems
--rm -rf build-debug
- rm -rf build-release
--
--# We want separate debug/release versions of the library, so we have to change
--# the LIBRARY_NAME for each build.
--# (We use perl instead of sed so that it works with MozillaBuild on Windows,
--# which has an ancient sed.)
--perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-debug'\''/' moz.build
--mkdir -p build-debug
--cd build-debug
--CXXFLAGS="${TLCXXFLAGS}" ../configure ${CONF_OPTS} --with-nspr-libs="$NSPR_LIBS" --with-nspr-cflags="$NSPR_INCLUDES" --enable-debug --disable-optimize --enable-js-diagnostics --enable-gczeal # --enable-root-analysis
--${MAKE} ${MAKE_OPTS}
--cd ..
-
- perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-release'\''/' moz.build
- mkdir -p build-release
-@@ -147,12 +135,9 @@
- mkdir -p ${INCLUDE_DIR_DEBUG}
- mkdir -p ${INCLUDE_DIR_RELEASE}
- cp -R -L mozjs31/js/src/build-release/dist/include/* ${INCLUDE_DIR_RELEASE}/
--cp -R -L mozjs31/js/src/build-debug/dist/include/* ${INCLUDE_DIR_DEBUG}/
-
- mkdir -p lib/
--cp -L mozjs31/js/src/build-debug/dist/lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_DST_SUFFIX}
- cp -L mozjs31/js/src/build-release/dist/lib/${LIB_PREFIX}mozjs31-ps-release${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-release${LIB_DST_SUFFIX}
--cp -L mozjs31/js/src/build-debug/dist/bin/${LIB_PREFIX}mozjs31-ps-debug${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-debug${DLL_DST_SUFFIX}
- cp -L mozjs31/js/src/build-release/dist/bin/${LIB_PREFIX}mozjs31-ps-release${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-release${DLL_DST_SUFFIX}
-
- # Flag that it's already been built successfully so we can skip it next time