summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/dominions2')
-rw-r--r--games-strategy/dominions2/Manifest5
-rw-r--r--games-strategy/dominions2/dominions2-2.16.ebuild103
-rw-r--r--games-strategy/dominions2/metadata.xml5
3 files changed, 113 insertions, 0 deletions
diff --git a/games-strategy/dominions2/Manifest b/games-strategy/dominions2/Manifest
new file mode 100644
index 000000000000..38e955be9ef8
--- /dev/null
+++ b/games-strategy/dominions2/Manifest
@@ -0,0 +1,5 @@
+DIST DOM2_Walkthrough.pdf 549897 SHA256 f6a3400f3fe03b89f23ec8c4492561bd58c684790f99669de0d7f1d08ff31855 SHA512 cc73bd7e95d8ce1528196f00d91d88a018b88471edade76672feb53b6ff728c9cc5f02e333312533a72842186833669ec290abffa8f51feb15e224b455987b39 WHIRLPOOL d79588e97e9c563f6ea52ef043b4e194e6e9efacffc48d32b5c0834e08e482eeeb6bc9052bb0efef4f0f3689be3f7b63499be74fce4119e49a09001f8d4039af
+DIST dominions2.png 1135 SHA256 530479327df7f2940a28eabb09217350fcc6009d0e81a9078d09d6b6515f6dc4 SHA512 1241c64a4acdd4740cc9440ba286b595c2e00a41182c014ef06b7184c3991f2df44e4677f3408b28cd25f928337a60c1e2859486c057ee3bdd393fb99b8d347f WHIRLPOOL 31c22cfa1ad318e70e0d81140854d990cd0b9ce448dc562f38ba5f655519ced2ff527939c361b51e5f8b5fe0e65d8790b711ea180be1ab7e7d98ae01be258f66
+DIST dompatch216_linux_ppc.tgz 1982323 SHA256 224e1cd46d8078798f185ca956a137fdf3b76b339f49cc5b2f3304d553ea0ad9 SHA512 6b1ff8b5a041c42193b8f369ee0ff242048fd589ffd9b610628a7bf7a0d159fe6e590b04b914ecbf3b94ef2b94a66a062be84d595777127d8f11311fa92c3ae9 WHIRLPOOL 8f2f35576026a7e88b90c912ee60cd2e39ffbfb7db228b0c5589d58f9988b3e9dfbc96551822649a03cbabf8efd7ff9697dfceb4f5ed8818a2bc07b6c318165c
+DIST dompatch216_linux_x86.tgz 1892714 SHA256 19efb6b3db9fdfdf752ac53dd4352df990b95f84a37cfc61f729ce77ae142dc1 SHA512 9bb2a024235585181f91d8414c07ce8c490fed5ddab9d25817b7ea01618f0f2cf8714fb39a4406abe88e25b354f14ba1ef2db79c39d4c30b4e399d1b60477c2d WHIRLPOOL 8fcdcc98e43d8392dd38b6bb1300a08eeff4782dd567d47b5471d4363a492b1eb90d6f3c589a8a768100df92d820da8cd3d9d1360cfebc671268663bf232a27b
+DIST manual_addenda.pdf 192454 SHA256 ecbed702d1dae4ef2a08a33d03fb4b92aec8cd39df48ac085ed2748dcd159ab4 SHA512 ec582e9685edf7164ba8e7c6c99880b30c8a6737d2d339eec2642196abd175857bfef2e1ea3da3ccb0110d441c477c8fad64d47fbb8b1aa39b405484eb548443 WHIRLPOOL de3a675380ab67329cb94b8d0c9669c57a855bf3f36f04dcd6d3c7b596dcef0c79f5943ffd9c8aaf3b83bc729368f0d463059934d720a216962a0f6770cf2424
diff --git a/games-strategy/dominions2/dominions2-2.16.ebuild b/games-strategy/dominions2/dominions2-2.16.ebuild
new file mode 100644
index 000000000000..e8cc420cbc7c
--- /dev/null
+++ b/games-strategy/dominions2/dominions2-2.16.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils cdrom games
+
+DESCRIPTION="Dominions 2: The Ascension Wars is an epic turn-based fantasy strategy game"
+HOMEPAGE="http://www.illwinter.com/dom2/index.html"
+SRC_URI="x86? (
+ http://www.shrapnelgames.com/downloads/dompatch${PV/\./}_linux_x86.tgz )
+ amd64? (
+ http://www.shrapnelgames.com/downloads/dompatch${PV/\./}_linux_x86.tgz )
+ ppc? (
+ http://www.shrapnelgames.com/downloads/dompatch${PV/\./}_linux_ppc.tgz )
+ doc? ( http://www.shrapnelgames.com/downloads/DOM2_Walkthrough.pdf
+ http://www.shrapnelgames.com/downloads/manual_addenda.pdf )
+ mirror://gentoo/${PN}.png"
+
+# I am not sure what license applies to Dominions II and I couldn't find
+# further information on their homepage or on the game CD :(
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RESTRICT="bindist strip"
+
+RDEPEND="
+ || (
+ ppc? (
+ media-libs/libsdl
+ virtual/opengl
+ virtual/glu
+ )
+ !ppc? (
+ media-libs/libsdl[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ )
+ )"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ mkdir -p "${S}"/patch || die
+ cd "${S}"/patch || die
+ if use x86 || use amd64 ; then
+ unpack dompatch${PV/\./}_linux_x86.tgz
+ elif use ppc ; then
+ unpack dompatch${PV/\./}_linux_ppc.tgz
+ fi
+}
+
+src_install() {
+ cdrom_get_cds dom2icon.ico
+ einfo "Copying files to harddisk... this may take a while..."
+
+ exeinto "${dir}"
+ if use amd64 || use x86 ; then
+ doexe "${CDROM_ROOT}"/bin_lin/x86/dom2*
+ elif use ppc ; then
+ doexe "${CDROM_ROOT}"/bin_lin/ppc/dom2*
+ fi
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/dominions2.app/Contents/Resources/*
+ dodoc "${CDROM_ROOT}"/doc/*
+
+ # applying the official patches just means overwriting some important
+ # files with their more recent versions:
+ einfo "Applying patch for version ${PV}..."
+ dodoc "${S}"/patch/doc/*
+ doexe "${S}"/patch/dom2
+ rm -rf "${S}"/patch/doc/ "${S}"/patch/dom2 || die
+ doins -r "${S}"/patch/*
+
+ if use doc; then
+ elog ""
+ elog "Installing extra documentation to '/usr/share/doc/${P}'"
+ elog ""
+ elog "You may want to study 'DOM2_Walkthrough.pdf' carefully if"
+ elog "you are new to Dominions II."
+ elog ""
+ dodoc "${DISTDIR}"/{DOM2_Walkthrough,manual_addenda}.pdf
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png
+
+ # update times
+ find "${D}" -exec touch '{}' \;
+
+ games_make_wrapper dominions2 ./dom2 "${dir}" "${dir}"
+ make_desktop_entry dominions2 "Dominions II" dominions2
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " dominions2"
+ echo
+}
diff --git a/games-strategy/dominions2/metadata.xml b/games-strategy/dominions2/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/dominions2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>