summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/netherearth/files')
-rw-r--r--games-strategy/netherearth/files/Makefile20
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-freeglut.patch18
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch139
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch23
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-ldflags.patch8
-rw-r--r--games-strategy/netherearth/files/netherearth-0.52-linux.patch47
6 files changed, 0 insertions, 255 deletions
diff --git a/games-strategy/netherearth/files/Makefile b/games-strategy/netherearth/files/Makefile
deleted file mode 100644
index 07c671a10e31..000000000000
--- a/games-strategy/netherearth/files/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# ls *.cpp
-#
-#3dobject-ase.cpp construction.cpp maps.cpp netherdebug.cpp radar.cpp
-#3dobject.cpp enemy_ai.cpp menu.cpp nethersave.cpp robot_ai.cpp
-#bitmap.cpp glprintf.cpp myglutaux.cpp particles.cpp robots.cpp
-#bullet.cpp main.cpp nether.cpp piece3dobject.cpp shadow3dobject.cpp
-#cmc.cpp mainmenu.cpp nethercycle.cpp quaternion.cpp vector.cpp
-
-
-SOURCES = 3dobject-ase.cpp 3dobject.cpp cmc.cpp nether.cpp piece3dobject.cpp vector.cpp bitmap.cpp bullet.cpp glprintf.cpp main.cpp mainmenu.cpp maps.cpp menu.cpp myglutaux.cpp nethercycle.cpp netherdebug.cpp nethersave.cpp particles.cpp construction.cpp quaternion.cpp radar.cpp enemy_ai.cpp robot_ai.cpp robots.cpp shadow3dobject.cpp
-OBJECTS = $(SOURCES:.cpp=.o)
-TARGET = nether_earth
-
-.cpp.o:
- g++ ${CXXFLAGS} -c $< -o $@
-
-all: $(TARGET)
-
-$(TARGET): $(OBJECTS)
- g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
diff --git a/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch b/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
deleted file mode 100644
index b61e1f139b04..000000000000
--- a/games-strategy/netherearth/files/netherearth-0.52-freeglut.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/main.cpp
-+++ b/main.cpp
-@@ -8,6 +8,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <GL/glut.h>
- #include "SDL/SDL.h"
- #include "SDL/SDL_mixer.h"
-
-@@ -144,6 +145,7 @@
- bool quit = false;
-
- load_configuration();
-+ glutInit(&argc, argv);
-
- screen_sfc = initialization((fullscreen ? SDL_FULLSCREEN : 0));
- if (screen_sfc==0) return 0;
diff --git a/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch b/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch
deleted file mode 100644
index 25f99be50fab..000000000000
--- a/games-strategy/netherearth/files/netherearth-0.52-gentoo-paths.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-diff -ud ../NetherEarth_v0.51-linsrc.orig/3dobject-ase.cpp ./3dobject-ase.cpp
---- ../NetherEarth_v0.51-linsrc.orig/3dobject-ase.cpp 2002-10-26 00:00:00.000000000 +0300
-+++ ./3dobject-ase.cpp 2004-04-16 21:42:55.000000000 +0300
-@@ -34,7 +34,7 @@
- char buffer[256];
- FILE *fp;
-
-- fp=fopen(file,"r+");
-+ fp=fopen(file,"r");
- if (fp==NULL) return false;
-
- /* Look for the materials: */
-diff -ud ../NetherEarth_v0.51-linsrc.orig/3dobject.cpp ./3dobject.cpp
---- ../NetherEarth_v0.51-linsrc.orig/3dobject.cpp 2004-01-06 20:49:00.000000000 +0200
-+++ ./3dobject.cpp 2004-04-16 21:43:44.000000000 +0300
-@@ -74,7 +74,7 @@
-
- int *smooth;
-
-- fp=fopen(file,"r+");
-+ fp=fopen(file,"r");
- if (fp==NULL) return false;
-
- /* Importar un fichero .ASC de 3DStudio */
-diff -ud ../NetherEarth_v0.51-linsrc.orig/bitmap.cpp ./bitmap.cpp
---- ../NetherEarth_v0.51-linsrc.orig/bitmap.cpp 2004-01-06 20:49:00.000000000 +0200
-+++ ./bitmap.cpp 2004-04-16 21:45:13.000000000 +0300
-@@ -14,7 +14,7 @@
- g=0;
- b=0;
-
-- fp=fopen(file,"rb+");
-+ fp=fopen(file,"rb");
- if (fp==NULL) return;
-
- /* Tag: */
-diff -ud ../NetherEarth_v0.51-linsrc.orig/mainmenu.cpp ./mainmenu.cpp
---- ../NetherEarth_v0.51-linsrc.orig/mainmenu.cpp 2004-01-06 20:50:00.000000000 +0200
-+++ ./mainmenu.cpp 2004-04-16 21:14:14.000000000 +0300
-@@ -6,6 +6,9 @@
- #include <dirent.h>
- #endif
-
-+#include <stdlib.h>
-+#include <fcntl.h>
-+#include <unistd.h>
- #include "string.h"
- #include "stdio.h"
- #include "math.h"
-@@ -483,8 +486,10 @@
- {
- int v;
- FILE *fp;
-+ char cfg_path[300];
-
-- fp=fopen("nether.cfg","r");
-+ sprintf(cfg_path, "%s/.netherearth/nether.cfg", getenv("HOME"));
-+ fp=fopen(cfg_path,"r");
- if (fp==0) return;
-
- if (2!=fscanf(fp,"%i %i",&SCREEN_X,&SCREEN_Y)) return;
-@@ -510,8 +515,12 @@
- void save_configuration(void)
- {
- FILE *fp;
-+ char cfg_path[300];
-
-- fp=fopen("nether.cfg","w");
-+ sprintf(cfg_path, "%s/.netherearth", getenv("HOME"));
-+ mkdir(cfg_path, 0755);
-+ sprintf(cfg_path, "%s/.netherearth/nether.cfg", getenv("HOME"));
-+ fp=fopen(cfg_path,"w");
- if (fp==0) return;
-
- fprintf(fp,"%i %i\n",SCREEN_X,SCREEN_Y);
-diff -ud ../NetherEarth_v0.51-linsrc.orig/nether.cpp ./nether.cpp
---- ../NetherEarth_v0.51-linsrc.orig/nether.cpp 2004-01-06 21:03:00.000000000 +0200
-+++ ./nether.cpp 2004-04-16 20:54:54.000000000 +0300
-@@ -1203,7 +1203,7 @@
- if (option_menu==(i+1)) glColor3f(1.0,0.0,0.0);
- else glColor3f(0.5,0.5,1.0);
- glTranslatef(0,-2,0);
-- sprintf(filename,"savedgame%i.txt",i);
-+ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), i);
- fp=fopen(filename,"r");
- if (fp==0) {
- scaledglprintf(0.01,0.01,"SLOT%i - EMPTY",i+1);
-@@ -1232,7 +1232,7 @@
- if (option_menu==(i+1)) glColor3f(1.0,0.0,0.0);
- else glColor3f(0.5,0.5,1.0);
- glTranslatef(0,-2,0);
-- sprintf(filename,"savedgame%i.txt",i);
-+ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), i);
- fp=fopen(filename,"r");
- if (fp==0) {
- scaledglprintf(0.01,0.01,"SLOT%i - EMPTY",i+1);
-@@ -1291,7 +1291,7 @@
- case 4:
- {
- char filename[80];
-- sprintf(filename,"savedgame%i.txt",option_menu-1);
-+ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), option_menu-1);
- save_game(filename);
- //save_debug_report("debugreport.txt");
- game_state=STATE_PAUSE;
-@@ -1326,7 +1326,7 @@
- case 4:
- {
- char filename[80];
-- sprintf(filename,"savedgame%i.txt",option_menu-1);
-+ sprintf(filename,"%s/.netherearth/savedgame%i.txt", getenv("HOME"), option_menu-1);
- killmenu(act_menu);
- load_game(filename);
- newmenu(act_menu);
-diff -ud ../NetherEarth_v0.51-linsrc.orig/nethersave.cpp ./nethersave.cpp
---- ../NetherEarth_v0.51-linsrc.orig/nethersave.cpp 2003-09-17 00:00:00.000000000 +0300
-+++ ./nethersave.cpp 2004-04-16 21:23:04.000000000 +0300
-@@ -2,6 +2,10 @@
- #include "windows.h"
- #endif
-
-+#include <stdlib.h>
-+#include <sys/types.h>
-+#include <fcntl.h>
-+#include <unistd.h>
- #include "string.h"
- #include "stdio.h"
- #include "math.h"
-@@ -40,7 +44,10 @@
- ROBOT *r;
- BULLET *bul;
- EXPLOSION *e;
-+ char tmp_path[300];
-
-+ sprintf(tmp_path, "%s/.netherearth", getenv("HOME"));
-+ mkdir(tmp_path, 0755);
- fp=fopen(filename,"w");
- if (fp==0) return false;
-
diff --git a/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch b/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
deleted file mode 100644
index 813f963db4c8..000000000000
--- a/games-strategy/netherearth/files/netherearth-0.52-glibc-212.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-http://bugs.gentoo.org/335137
-
---- sources/mainmenu.cpp
-+++ sources/mainmenu.cpp
-@@ -3,6 +3,7 @@
- #else
- #include <stddef.h>
- #include <sys/types.h>
-+#include <sys/stat.h>
- #include <dirent.h>
- #endif
-
---- sources/nethersave.cpp
-+++ sources/nethersave.cpp
-@@ -1,5 +1,8 @@
- #ifdef _WIN32
- #include "windows.h"
-+#else
-+#include <sys/types.h>
-+#include <sys/stat.h>
- #endif
-
- #include "string.h"
diff --git a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch b/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
deleted file mode 100644
index 7d81f912764f..000000000000
--- a/games-strategy/netherearth/files/netherearth-0.52-ldflags.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/Makefile.old 2010-10-12 09:30:19.000000000 +0200
-+++ b/Makefile 2010-10-12 09:30:38.000000000 +0200
-@@ -17,4 +17,4 @@
- all: $(TARGET)
-
- $(TARGET): $(OBJECTS)
-- g++ $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
-+ g++ $(LDFLAGS) $(OBJECTS) -o $(TARGET) -lGL -lGLU -lglut -lSDL -lSDL_mixer -lpthread
diff --git a/games-strategy/netherearth/files/netherearth-0.52-linux.patch b/games-strategy/netherearth/files/netherearth-0.52-linux.patch
deleted file mode 100644
index 6c4c0d1e9733..000000000000
--- a/games-strategy/netherearth/files/netherearth-0.52-linux.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -burN sources/glprintf.cpp sources-linux/glprintf.cpp
---- sources/glprintf.cpp 2002-10-26 00:17:00.000000000 +0200
-+++ sources-linux/glprintf.cpp 2005-06-18 18:22:54.000000000 +0200
-@@ -3,6 +3,7 @@
- #endif
- #include "GL/gl.h"
-
-+#include "string.h"
- #include "stdio.h"
- #include "stdarg.h"
- #include "GL/gl.h"
-diff -burN sources/list.h sources-linux/list.h
---- sources/list.h 2002-10-27 12:17:00.000000000 +0100
-+++ sources-linux/list.h 2005-06-18 18:21:34.000000000 +0200
-@@ -1,6 +1,9 @@
- #ifndef GENERIC_LIST
- #define GENERIC_LIST
-
-+
-+#include "stdlib.h"
-+
- /*
- Funciones para LISTAS:
-
-diff -burN sources/maps.cpp sources-linux/maps.cpp
---- sources/maps.cpp 2005-05-05 23:42:00.000000000 +0200
-+++ sources-linux/maps.cpp 2005-06-18 18:23:05.000000000 +0200
-@@ -3,6 +3,7 @@
- #endif
-
- #include "stdio.h"
-+#include "string.h"
-
- #include "GL/gl.h"
- #include "GL/glu.h"
-diff -burN sources/myglutaux.cpp sources-linux/myglutaux.cpp
---- sources/myglutaux.cpp 2002-10-26 00:17:00.000000000 +0200
-+++ sources-linux/myglutaux.cpp 2005-06-18 18:23:29.000000000 +0200
-@@ -5,6 +5,8 @@
- #include <GL/gl.h>
- #include "GL/glut.h"
-
-+#include "string.h"
-+#include "stdlib.h"
- #include "stdio.h"
- #include "math.h"
- #include "vector.h"