summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot/colobot-0.1.12.ebuild7
-rw-r--r--games-strategy/colobot/files/colobot-0.1.12-includes.patch23
2 files changed, 29 insertions, 1 deletions
diff --git a/games-strategy/colobot/colobot-0.1.12.ebuild b/games-strategy/colobot/colobot-0.1.12.ebuild
index 1611ef4a1d61..7f53954e4017 100644
--- a/games-strategy/colobot/colobot-0.1.12.ebuild
+++ b/games-strategy/colobot/colobot-0.1.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,11 @@ DEPEND="
RDEPEND="${DEPEND}
games-strategy/colobot-data"
+PATCHES=(
+ # https://github.com/colobot/colobot/pull/1300
+ "${FILESDIR}"/${P}-includes.patch
+)
+
src_prepare() {
cmake-utils_src_prepare
diff --git a/games-strategy/colobot/files/colobot-0.1.12-includes.patch b/games-strategy/colobot/files/colobot-0.1.12-includes.patch
new file mode 100644
index 000000000000..1fb3a2730c44
--- /dev/null
+++ b/games-strategy/colobot/files/colobot-0.1.12-includes.patch
@@ -0,0 +1,23 @@
+From 2cfab017938e1cf44f633647eec2ccc2ed1da38b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 14 May 2020 10:35:01 +0200
+Subject: [PATCH] Fix missing <limits> include
+
+Add missing <limits> include for std::numeric_limits. This fixes
+build failure after boost stopped implicitly including it for us.
+---
+ src/script/script.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/script/script.h b/src/script/script.h
+index bc64dc232..dd4e02ff4 100644
+--- a/src/script/script.h
++++ b/src/script/script.h
+@@ -27,6 +27,7 @@
+ #include "CBot/CBot.h"
+
+ #include <memory>
++#include <limits>
+ #include <string>
+ #include <boost/optional.hpp>
+