summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/Manifest3
-rw-r--r--games-strategy/wesnoth/wesnoth-1.14.11.ebuild111
-rw-r--r--games-strategy/wesnoth/wesnoth-1.15.3.ebuild9
3 files changed, 116 insertions, 7 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index d9c0f9155fd7..cf60e399b6c7 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,3 +1,4 @@
+DIST wesnoth-1.14.11.tar.gz 500178610 BLAKE2B 27af594bc86845eedb8cd8e45c814c3583e35bd94942947f91b6fa888018ae203dbd100e01ab26b5cd59712895151049105ff446d8ad3a8b2d86133d913a92cc SHA512 3c878f679e51d3657dd4d76205bdeadd6a1a95d0771cd7ab0e29f33f36e32f1963e4a96f4529dbc4b860183b3cb5a4219e86108e0e26194b8a32d3d08a5fd469
DIST wesnoth-1.14.7.tar.gz 493837595 BLAKE2B a80781d4f9ec79514c6431c5d45a6cdcb913aabc6329cefe46e7980805d06b60d479110bb6432f2c35a058e551da6b6fa8e0e4f6f1bdf9a159f6329ddb74aa2a SHA512 dbca2b904147f592cc712b11d6414a47bd557d3c677e6b3eacb4fc1ca5420a264f15fdbe45c8c3469ecfb5d1ffa1ac19cceb58c1378aec0e8b4597baa348ca3b
DIST wesnoth-1.14.9.tar.gz 497393449 BLAKE2B b5235de6ce84164ef97a105339549a8a1009d7b7ed243ae355994610e56afc584b8a37b1275e0b929729a24cd2eb94d4c208e7bd22e79b76113a1e1b91c8f92d SHA512 b3e93956a40ffc48dd02e118be1d46854a2eed34ad0dca3fb34a28d0b58b4b563cb5cca588208f3525300bf075786bebe95a25c045c8098a0bdfe531a2d81e4f
-DIST wesnoth-1.15.2.tar.gz 500575489 BLAKE2B c94ff72034f0253c3a2ceb29f10617227c407baa6365116a8cd23c70dd960d9898f5a6291235347769780798438380fe78ada8fb75b4dd83e2d2831f495360ae SHA512 c15bdc214147a222ceb2e6243a75e2dbe4f10eb6153a32c10f37b1ec163a7e0b8f6fb12747917602773fd149d23dc8a6b3ed0b0c017f44f713388743126d6b94
+DIST wesnoth-1.15.3.tar.gz 495645949 BLAKE2B aa6b8636ff1b134af5e6e9cfbefefee3189a46ccd20c2a3a3f361d77d3de48d1ae38bf8376087b6292bcacc465ad72bd60ab7aa16b3ca536ce963b6f644b8ff1 SHA512 2a5993c2c2f41939346f88104722e31a1bd0f68b39c84bdf657a7156c1348e6c65089e2766c088a2b5a2c2df8c3cd8c5cf736d66538c87cf175585634e31adbb
diff --git a/games-strategy/wesnoth/wesnoth-1.14.11.ebuild b/games-strategy/wesnoth/wesnoth-1.14.11.ebuild
new file mode 100644
index 000000000000..f11fafb5b6da
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.14.11.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="dbus dedicated doc fribidi libressl nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ >=dev-libs/boost-1.50:=[nls,threads,icu]
+ >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ >=media-libs/sdl2-ttf-2.0.12
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ fribidi? ( dev-libs/fribidi )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+
+ # Work around eclass
+ append-flags -UNDEBUG
+
+ if use dedicated || use server ; then
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_FRIBIDI="$(usex fribidi)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server; then
+ rmdir "${ED}/run/wesnothd" || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}
diff --git a/games-strategy/wesnoth/wesnoth-1.15.3.ebuild b/games-strategy/wesnoth/wesnoth-1.15.3.ebuild
index e78b5be4d42a..f11fafb5b6da 100644
--- a/games-strategy/wesnoth/wesnoth-1.15.3.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.15.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake user toolchain-funcs xdg
+inherit cmake toolchain-funcs xdg
DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
HOMEPAGE="http://www.wesnoth.org
@@ -19,6 +19,8 @@ fi
IUSE="dbus dedicated doc fribidi libressl nls server"
RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
>=dev-libs/boost-1.50:=[nls,threads,icu]
>=media-libs/libsdl2-2.0.4:0[joystick,video,X]
!dedicated? (
@@ -44,11 +46,6 @@ BDEPEND="
virtual/pkgconfig
"
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 /bin/bash -1 ${PN}
-}
-
src_prepare() {
cmake_src_prepare