summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.0_pre20200418.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200418.ebuild b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200418.ebuild
index 80e7682041a2..fb3053465056 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200418.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200418.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop xdg cmake
+inherit desktop toolchain-funcs xdg cmake
DESCRIPTION="Open source remake of The Settlers II: Gold Edition (needs original data files)"
HOMEPAGE="https://www.siedler25.org/"
@@ -97,10 +97,9 @@ src_configure() {
-DRTTR_VERSION="${PV}"
)
- if use test ; then
- einfo "Forcing clang due to USE=test."
- CC=${CHOST}-clang
- CXX=${CHOST}-clang++
+ if use test && tc-is-gcc; then
+ # Work around libasan and libsandbox both wanting to be first.
+ append-ldflags -static-libasan
fi
cmake_src_configure