summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/freeorion-0.4.7.1-r2.ebuild (renamed from games-strategy/freeorion/freeorion-0.4.7.1-r1.ebuild)6
-rw-r--r--games-strategy/freeorion/freeorion-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/games-strategy/freeorion/freeorion-0.4.7.1-r1.ebuild b/games-strategy/freeorion/freeorion-0.4.7.1-r2.ebuild
index d0d5447656d7..59dd595f13e8 100644
--- a/games-strategy/freeorion/freeorion-0.4.7.1-r1.ebuild
+++ b/games-strategy/freeorion/freeorion-0.4.7.1-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1 gnome2-utils
+inherit cmake-utils python-single-r1 gnome2-utils
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
@@ -24,7 +24,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=dev-libs/boost-1.56:=[python,threads]
+ >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
media-libs/freealut
media-libs/freetype
media-libs/glew:*
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
# build system is using FindPythonLibs.cmake which needs python:2
- python-any-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/games-strategy/freeorion/freeorion-9999.ebuild b/games-strategy/freeorion/freeorion-9999.ebuild
index d0d5447656d7..59dd595f13e8 100644
--- a/games-strategy/freeorion/freeorion-9999.ebuild
+++ b/games-strategy/freeorion/freeorion-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils python-any-r1 gnome2-utils
+inherit cmake-utils python-single-r1 gnome2-utils
DESCRIPTION="A free turn-based space empire and galactic conquest game"
HOMEPAGE="http://www.freeorion.org"
@@ -24,7 +24,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=dev-libs/boost-1.56:=[python,threads]
+ >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
media-libs/freealut
media-libs/freetype
media-libs/glew:*
@@ -46,7 +46,7 @@ DEPEND="${RDEPEND}
pkg_setup() {
# build system is using FindPythonLibs.cmake which needs python:2
- python-any-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {