summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-util/wit')
-rw-r--r--games-util/wit/Manifest2
-rw-r--r--games-util/wit/files/wit-2.30a-makefile.patch120
-rw-r--r--games-util/wit/files/wit-2.30a-no-exec-stack.patch9
-rw-r--r--games-util/wit/files/wit-2.30a-sizeof-pointer-memaccess.patch31
-rw-r--r--games-util/wit/metadata.xml11
-rw-r--r--games-util/wit/wit-2.30a.ebuild39
-rw-r--r--games-util/wit/wit-2.31a.ebuild39
7 files changed, 251 insertions, 0 deletions
diff --git a/games-util/wit/Manifest b/games-util/wit/Manifest
new file mode 100644
index 000000000000..ef5e17032900
--- /dev/null
+++ b/games-util/wit/Manifest
@@ -0,0 +1,2 @@
+DIST wit-2.30a.tar.xz 716252 SHA256 5a63e554f69462474825c056abbd1411dcd0d6a24e9232a97a6c0d118eebe970 SHA512 177ae16a39b474116925a8b6cdae465ceb3e0a3cac2d3b704703ab59eed0cf380d63ad6617b56248c9030aa5250befebc31f06de1c97b8c1801c90922e8bdc69 WHIRLPOOL c5cd75213c7e25a887593d34a5812f68c9e5d8e5806d76e05201f4a1f6e74e797740c384fd06c6fe225556729a073e00259b44ed1d623313beea51b8bde3661e
+DIST wit-2.31a.tar.xz 717292 SHA256 73c6496f8c7477f5c25aa3bba981b5e98fb58eeb668d3a877a019a1c29c98cad SHA512 69ec679082e6fac2545d0af0ec3899a5d4a68fd10e26d8678bdd6facf3f80b83ea89347f54e2e2f553c91ecc4fa969a64021b003f29c18a4acea4cc1febebfe0 WHIRLPOOL f70c3e429fdc7ee91015f34b43df8328c7134be1f2309c9239d99cbce983022a33cf9e140311fcd7112a540899cdb8ddea97747c6b165c69da713283705824dd
diff --git a/games-util/wit/files/wit-2.30a-makefile.patch b/games-util/wit/files/wit-2.30a-makefile.patch
new file mode 100644
index 000000000000..d705487cd8ba
--- /dev/null
+++ b/games-util/wit/files/wit-2.30a-makefile.patch
@@ -0,0 +1,120 @@
+--- wit-2.30a/Makefile
++++ wit-2.30a/Makefile
+@@ -190,8 +190,8 @@
+ endif
+
+ # lib summary
+-LIB_LIST += libbz2 lzma
+-LIB_OBJECTS += $(LIBBZ2_OBJ) $(LZMA_OBJ)
++LIB_LIST += lzma
++LIB_OBJECTS += $(LZMA_OBJ)
+ RM_FILES += $(foreach l,$(LIB_LIST),src/$(l)/*.{d,o})
+
+
+@@ -273,10 +274,8 @@
+ DEFINES1 += -D_LZMA_PROB32=1 # LZMA option
+ DEFINES = $(strip $(DEFINES1) $(MODE) $(XDEF))
+
+-CFLAGS += -fomit-frame-pointer -fno-strict-aliasing -funroll-loops
+ CFLAGS += -Wall -Wno-parentheses -Wno-unused-function
+-#CFLAGS += -O3 -Isrc/libwbfs -Isrc/lzma -Isrc -I$(UI) -I. -Iwork
+-CFLAGS += -O3 -Isrc/libwbfs -Isrc -I$(UI) -I. -Iwork
++CFLAGS += -Isrc/libwbfs -Isrc -I$(UI) -I. -Iwork
+ ifeq ($(SYSTEM),mac)
+ CFLAGS += -I/usr/local/include
+ endif
+@@ -291,7 +290,7 @@
+ ifeq ($(HAVE_ZLIB),1)
+ LIBS += -lz
+ endif
+-LIBS += $(XLIBS)
++LIBS += $(XLIBS) -lbz2
+
+ DISTRIB_RM = ./wit-v$(VERSION)-r
+ DISTRIB_BASE = wit-v$(VERSION)-r$(REVISION_NEXT)
+@@ -344,71 +343,60 @@
+ # general rules
+
+ $(ALL_TOOLS_X): %: %.o $(ALL_OBJECTS) $(TOBJ_ALL) Makefile | $(HELPER_TOOLS)
+- @printf "$(LOGFORMAT)" tool "$@" "$(MODE) $(TOPT_$@) $(TOBJ_$@)"
+- @$(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
++ $(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
+ $(ALL_OBJECTS) $(TOBJ_$@) $(LIBS) $(TOPT_$@) -o $@
+- @if test -f $@.exe; then $(STRIP) $@.exe; else $(STRIP) $@; fi
+
+- @mkdir -p bin/$(SYSTEM) bin/$(SYSTEM)/debug
+- @if test -s $(MODE_FILE) && grep -Fq -e -DDEBUG $(MODE_FILE); \
++ mkdir -p bin/$(SYSTEM) bin/$(SYSTEM)/debug
++ if test -s $(MODE_FILE) && grep -Fq -e -DDEBUG $(MODE_FILE); \
+ then cp -p $@ bin/$(SYSTEM)/debug/; \
+ else cp -p $@ bin/; cp -p $@ bin/$(SYSTEM)/; fi
+
+ #--------------------------
+
+ $(HELPER_TOOLS): %: %.o $(ALL_OBJECTS) $(UI_TABS) Makefile
+- @printf "$(LOGFORMAT)" helper "$@ $(TOBJ_$@)" "$(MODE)"
+- @$(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
++ $(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
+ $(ALL_OBJECTS) $(TOBJ_$@) $(LIBS) -o $@
+
+ #--------------------------
+
+ $(WDF_LINKS): wdf
+- @printf "$(LOGFORMAT)" "link" "wdf -> $@" ""
+- @ln -f wdf "$@"
++ ln -f wdf "$@"
+
+ #--------------------------
+
+ $(UI_OBJECTS): %.o: %.c ui-%.c ui-%.h version.h Makefile
+- @printf "$(LOGFORMAT)" +object "$@" "$(MODE)"
+- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
++ $(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
+
+ #--------------------------
+
+ $(C_OBJECTS): %.o: %.c version.h Makefile $(TEXT_FILES)
+- @printf "$(LOGFORMAT)" object "$@" "$(MODE)"
+- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
++ $(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
+
+ #--------------------------
+
+ $(ASM_OBJECTS): %.o: %.S Makefile
+- @printf "$(LOGFORMAT)" asm "$@" "$(MODE)"
+- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
++ $(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
+
+ #--------------------------
+
+ $(SETUP_FILES): templates.sed $(SETUP_DIR)/$@
+- @printf "$(LOGFORMAT)" create "$@" ""
+- @chmod 775 $(GEN_TEMPLATE)
+- @$(GEN_TEMPLATE) $@
++ chmod 775 $(GEN_TEMPLATE)
++ $(GEN_TEMPLATE) $@
+
+ #--------------------------
+
+ $(TEXT_FILES): $(GEN_TEXT_FILE) $(TEXT_DIR)/$@
+- @printf "$(LOGFORMAT)" text "$@" ""
+- @chmod 775 $(GEN_TEXT_FILE)
+- @$(GEN_TEXT_FILE) $(TEXT_DIR) $@
++ chmod 775 $(GEN_TEXT_FILE)
++ $(GEN_TEXT_FILE) $(TEXT_DIR) $@
+
+ #--------------------------
+
+ $(UI_FILES): gen-ui.c tab-ui.c ui.h $(UI_TABS) | gen-ui
+- @printf "$(LOGFORMAT)" run gen-ui ""
+- @./gen-ui
++ ./gen-ui
+
+ .PHONY : ui
+ ui : gen-ui
+- @printf "$(LOGFORMAT)" run gen-ui ""
+- @./gen-ui
++ ./gen-ui
+
+ #
+ ###############################################################################
diff --git a/games-util/wit/files/wit-2.30a-no-exec-stack.patch b/games-util/wit/files/wit-2.30a-no-exec-stack.patch
new file mode 100644
index 000000000000..db91b45cfcb1
--- /dev/null
+++ b/games-util/wit/files/wit-2.30a-no-exec-stack.patch
@@ -0,0 +1,9 @@
+--- wit-2.30a/src/crypto/ssl-asm.S
++++ wit-2.30a/src/crypto/ssl-asm.S
+@@ -37,3 +37,6 @@
+ #define WIT_INCLUDE_SSL_ASM
+ #include "ssl-asm.h"
+
++#if defined(__linux__) && defined(__ELF__)
++.section .note.GNU-stack,"",%progbits
++#endif
diff --git a/games-util/wit/files/wit-2.30a-sizeof-pointer-memaccess.patch b/games-util/wit/files/wit-2.30a-sizeof-pointer-memaccess.patch
new file mode 100644
index 000000000000..32ef56f8653c
--- /dev/null
+++ b/games-util/wit/files/wit-2.30a-sizeof-pointer-memaccess.patch
@@ -0,0 +1,31 @@
+--- wit-2.30a/src/lib-file.c
++++ wit-2.30a/src/lib-file.c
+@@ -3510,7 +3510,7 @@
+ DASSERT(fmap);
+ DASSERT(n_elem>0);
+
+- memset(fmap,0,sizeof(fmap));
++ memset(fmap,0,sizeof(*fmap));
+
+ u64 last_off = 0;
+ while ( last_off < file->st.st_size )
+--- wit-2.30a/src/wfuse.c
++++ wit-2.30a/src/wfuse.c
+@@ -340,7 +340,7 @@
+ }
+ ResetWBFS(df->wbfs);
+ FREE(df->wbfs);
+- memset(df,0,sizeof(df));
++ memset(df,0,sizeof(*df));
+ n_dfile--;
+ }
+
+@@ -352,7 +352,7 @@
+
+ if (found_df)
+ {
+- memset(found_df,0,sizeof(found_df));
++ memset(found_df,0,sizeof(*found_df));
+ WBFS_t * wbfs = MALLOC(sizeof(*wbfs));
+ InitializeWBFS(wbfs);
+ enumError err = OpenWBFS(wbfs,source_file,false,true,0);
diff --git a/games-util/wit/metadata.xml b/games-util/wit/metadata.xml
new file mode 100644
index 000000000000..b9f7ddab2bc2
--- /dev/null
+++ b/games-util/wit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="fuse">Enable image mount support via fuse</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-util/wit/wit-2.30a.ebuild b/games-util/wit/wit-2.30a.ebuild
new file mode 100644
index 000000000000..b3f9c40ac312
--- /dev/null
+++ b/games-util/wit/wit-2.30a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A set of command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
+HOMEPAGE="http://wit.wiimm.de/"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse +zlib"
+
+RDEPEND="
+ app-arch/bzip2
+ fuse? ( sys-fs/fuse )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+DOCS="doc/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-no-exec-stack.patch
+ epatch "${FILESDIR}"/${P}-sizeof-pointer-memaccess.patch
+}
+
+src_compile() {
+ export NO_FUSE=$(usex fuse 0 1)
+ export NO_ZLIB=$(usex zlib 0 1)
+
+ emake INSTALL_PATH="${D}"/usr CC="$(tc-getCC)"
+ emake doc
+}
diff --git a/games-util/wit/wit-2.31a.ebuild b/games-util/wit/wit-2.31a.ebuild
new file mode 100644
index 000000000000..7ec7ea3c1bb6
--- /dev/null
+++ b/games-util/wit/wit-2.31a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A set of command line tools to manipulate Wii/GameCube ISO images and WBFS containers"
+HOMEPAGE="http://wit.wiimm.de/"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fuse +zlib"
+
+RDEPEND="
+ app-arch/bzip2
+ fuse? ( sys-fs/fuse )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+
+DOCS="doc/*.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.30a-makefile.patch
+ epatch "${FILESDIR}"/${PN}-2.30a-no-exec-stack.patch
+ epatch "${FILESDIR}"/${PN}-2.30a-sizeof-pointer-memaccess.patch
+}
+
+src_compile() {
+ export NO_FUSE=$(usex fuse 0 1)
+ export NO_ZLIB=$(usex zlib 0 1)
+
+ emake INSTALL_PATH="${D}"/usr CC="$(tc-getCC)"
+ emake doc
+}