summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-desktop')
-rw-r--r--gnome-base/gnome-desktop/Manifest1
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild2
-rw-r--r--gnome-base/gnome-desktop/gnome-desktop-3.20.2.ebuild64
3 files changed, 66 insertions, 1 deletions
diff --git a/gnome-base/gnome-desktop/Manifest b/gnome-base/gnome-desktop/Manifest
index fdce24b088e2..508d25c890fd 100644
--- a/gnome-base/gnome-desktop/Manifest
+++ b/gnome-base/gnome-desktop/Manifest
@@ -1,2 +1,3 @@
DIST gnome-desktop-2.32.1.tar.bz2 1633847 SHA256 55cbecf67efe1fa1e57ac966520a7c46d799c8ba3c652a1219f60cafccb3739d SHA512 b8084d08366dab661a7ee369cd03ba62beddbdfa9a36b988b7d13d207b33d6916f7fa8691717fba7b6a70d8276779e35360b1dc385e6ec876f30ea7b8b373c28 WHIRLPOOL 0889e79b1b3956b0ef1330f661676b77bdb40e8110657ea7f4035618ea023fc4b35364629d68741f042c0b971db9fa4c7731065717612486f7546e07fe048a0d
DIST gnome-desktop-3.18.2.tar.xz 1091568 SHA256 ddd46d022de137543a71f50c7392b32f9b98d5d3f2b53040b35f5802de2e7b56 SHA512 791a320f740f9d4da2a4cd08eaeec6598dab2b338ba1311ce3deb9e6ee4602765af45f7ba57e5a68217e87b718f991b0ba106d21be321d63e4aaa4514a3a4a81 WHIRLPOOL 0afef8a52fa0197309933204d8b022b18690e48d63882f7de4d102eb1d2791b1c4082805d9161cf035067b31a2ed553c0258d048a7d627f9a65e6fcd8590c7d2
+DIST gnome-desktop-3.20.2.tar.xz 1093172 SHA256 492c2da7aa8c3a8b65796e8171fc8f0dfb5d322dd2799c0d76392e1fb061e2b2 SHA512 034e412cb5a062e14093240bda6389a493fd705bcc799c55e4834b3a386cf50471073712a5cb723e6e6d0652241b6a2e0b4977758eab27a216725bff6180a0e8 WHIRLPOOL e2cca6f1275b65067e07f80928f14fb564294fa9c0f3f5cfecf5dbeb369148438de24df2bbda8936c5c2739887023eeeb0fb821fe30b05f7bcc40edb2fbf1b87
diff --git a/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
index c2084d83e473..468fb545b0f7 100644
--- a/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
+++ b/gnome-base/gnome-desktop/gnome-desktop-2.32.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/gnome-base/gnome-desktop/gnome-desktop-3.20.2.ebuild b/gnome-base/gnome-desktop/gnome-desktop-3.20.2.ebuild
new file mode 100644
index 000000000000..cf13d94d4df9
--- /dev/null
+++ b/gnome-base/gnome-desktop/gnome-desktop-3.20.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 virtualx
+
+DESCRIPTION="Libraries for the gnome desktop that are not part of the UI"
+HOMEPAGE="https://git.gnome.org/browse/gnome-desktop"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="3/12" # subslot = libgnome-desktop-3 soname version
+IUSE="debug +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x86-solaris"
+
+# cairo[X] needed for gnome-bg
+COMMON_DEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.44.0:2[dbus]
+ >=x11-libs/gdk-pixbuf-2.33.0:2[introspection?]
+ >=x11-libs/gtk+-3.3.6:3[X,introspection?]
+ >=x11-libs/libXext-1.1
+ >=x11-libs/libXrandr-1.3
+ x11-libs/cairo:=[X]
+ x11-libs/libX11
+ x11-misc/xkeyboard-config
+ >=gnome-base/gsettings-desktop-schemas-3.5.91
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-desktop-2.32.1-r1:2[doc]
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.6
+ dev-util/itstool
+ sys-devel/gettext
+ x11-proto/xproto
+ >=x11-proto/randrproto-1.2
+ virtual/pkgconfig
+"
+
+# Includes X11/Xatom.h in libgnome-desktop/gnome-bg.c which comes from xproto
+# Includes X11/extensions/Xrandr.h that includes randr.h from randrproto (and
+# eventually libXrandr shouldn't RDEPEND on randrproto)
+
+src_configure() {
+ # Note: do *not* use "--with-pnp-ids-path" argument. Otherwise, the pnp.ids
+ # file (needed by other packages such as >=gnome-settings-daemon-3.1.2)
+ # will not get installed in ${pnpdatadir} (/usr/share/libgnome-desktop-3.0).
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-distributor=Gentoo \
+ --enable-desktop-docs \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable debug debug-tools) \
+ $(use_enable introspection)
+}
+
+src_test() {
+ virtx emake check
+}