summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/pch-session/Manifest1
-rw-r--r--gnome-extra/pch-session/pch-session-3.30.0.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/pch-session/Manifest b/gnome-extra/pch-session/Manifest
index 9dfdf3a5c609..8c9d52e01304 100644
--- a/gnome-extra/pch-session/Manifest
+++ b/gnome-extra/pch-session/Manifest
@@ -1 +1,2 @@
+DIST pch-session-3.30.0.1.tar.bz2 8854 BLAKE2B 55e90c00d3637d21b80ec87db96561a43d4f770ffcc6d90c7c83189ab979565cbeada0dfb64cb3d10d72c6f4e40466345db2023b930971bb6b784a0f7c469551 SHA512 dbb6a28cc1cff37992f717285476b73201a5d96de682fa2e91774f644bd8870cbd6444f768c1395b81a8ba0fe36e60404343251a66d339ae6acfc2a7f47127f9
DIST pch-session-3.30.0.tar.bz2 8865 BLAKE2B ee6b0b3a621f609a89392c21fd03dfd14679b2007a135b85795963170ceae49ea913f5ba587e56e0c8ff44efef1602e91da4648379c4412a6c21c5ae6f3fa21d SHA512 3994d7dbd7587fc8d65e1f561cc5f522ac68c86578b97279239fcc2e535e2c4a7f179793312d66cd8c3e7876d8d217e98a22b2f50eb79c54343117dc1c3afaaa
diff --git a/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild b/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
new file mode 100644
index 000000000000..ca53eeb88fa6
--- /dev/null
+++ b/gnome-extra/pch-session/pch-session-3.30.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Unofficial gnome based session with different default settings and extensions"
+HOMEPAGE="https://gitlab.com/pachoramos/pch-session"
+SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=gnome-base/gnome-shell-3.30
+ gnome-extra/gnome-shell-extensions
+ gnome-extra/gnome-shell-extension-dash-to-panel
+ gnome-extra/gnome-shell-extension-desktop-icons
+ gnome-extra/gnome-shell-extension-gsconnect
+ gnome-extra/gnome-shell-extensions-topicons-plus
+"
+BDEPEND=""
+DEPEND=""
+
+src_install() {
+ insinto /usr
+ doins -r usr/.
+ einstalldocs
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}