summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-apps/preferences')
-rw-r--r--gnustep-apps/preferences/Manifest2
-rw-r--r--gnustep-apps/preferences/files/Preferences-nocreate-extra-dirs.patch18
-rw-r--r--gnustep-apps/preferences/files/preferences-gnustep-make2.patch164
-rw-r--r--gnustep-apps/preferences/metadata.xml9
-rw-r--r--gnustep-apps/preferences/preferences-1.3.0_pre20061204-r1.ebuild31
-rw-r--r--gnustep-apps/preferences/preferences-1.3.0_pre20100523.ebuild25
6 files changed, 249 insertions, 0 deletions
diff --git a/gnustep-apps/preferences/Manifest b/gnustep-apps/preferences/Manifest
new file mode 100644
index 000000000000..48f629df2e7e
--- /dev/null
+++ b/gnustep-apps/preferences/Manifest
@@ -0,0 +1,2 @@
+DIST preferences-1.3.0_pre20061204.tar.gz 230142 SHA256 af60134c5eeb7ed52b7209aacbc93ce64b9526c56a9ca2351c9bd9b872f2dbd7
+DIST preferences-1.3.0_pre20100523.tar.gz 428922 SHA256 f07a9a2c4daa265f4619af38669eb7ddc4d221d601f75faff39bd7f29afd3e68
diff --git a/gnustep-apps/preferences/files/Preferences-nocreate-extra-dirs.patch b/gnustep-apps/preferences/files/Preferences-nocreate-extra-dirs.patch
new file mode 100644
index 000000000000..0710c90906c6
--- /dev/null
+++ b/gnustep-apps/preferences/files/Preferences-nocreate-extra-dirs.patch
@@ -0,0 +1,18 @@
+diff -ur Preferences.backup/GNUmakefile.preamble Preferences/GNUmakefile.preamble
+--- Preferences.backup/GNUmakefile.preamble 2003-08-16 13:19:29.000000000 -0400
++++ Preferences/GNUmakefile.preamble 2004-06-28 19:51:30.104604048 -0400
+@@ -49,8 +49,8 @@
+ GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
+
+ # Additional directories to be created during installation
+-ADDITIONAL_INSTALL_DIRS += \
+- $(GNUSTEP_USER_ROOT)/Library/Preferences \
+- $(GNUSTEP_LOCAL_ROOT)/Library/Preferences \
+- $(GNUSTEP_NETWORK_ROOT)/Library/Preferences \
+- $(GNUSTEP_SYSTEM_ROOT)/Library/Preferences
++#ADDITIONAL_INSTALL_DIRS += \
++# $(GNUSTEP_USER_ROOT)/Library/Preferences
++# $(GNUSTEP_LOCAL_ROOT)/Library/Preferences
++# $(GNUSTEP_NETWORK_ROOT)/Library/Preferences
++# $(GNUSTEP_SYSTEM_ROOT)/Library/Preferences
+Only in Preferences: GNUmakefile.preamble~
diff --git a/gnustep-apps/preferences/files/preferences-gnustep-make2.patch b/gnustep-apps/preferences/files/preferences-gnustep-make2.patch
new file mode 100644
index 000000000000..3ac6a7c4f248
--- /dev/null
+++ b/gnustep-apps/preferences/files/preferences-gnustep-make2.patch
@@ -0,0 +1,164 @@
+diff -Naur Preferences.orig/GNUmakefile Preferences/GNUmakefile
+--- Preferences.orig/GNUmakefile 2004-06-11 00:38:31.000000000 +0200
++++ Preferences/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -55,7 +55,7 @@
+ export TOP_SRCDIR := $(CURDIR)/../..
+ endif
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ #
+ # Resource files
+diff -Naur Preferences.orig/GNUmakefile.preamble Preferences/GNUmakefile.preamble
+--- Preferences.orig/GNUmakefile.preamble 2007-11-06 15:49:02.000000000 +0100
++++ Preferences/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -37,7 +37,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ #ADDITIONAL_INSTALL_DIRS += \
+diff -Naur Preferences.orig/Modules/Colors/GNUmakefile Preferences/Modules/Colors/GNUmakefile
+--- Preferences.orig/Modules/Colors/GNUmakefile 2006-09-03 19:15:12.000000000 +0200
++++ Preferences/Modules/Colors/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -3,10 +3,10 @@
+ BUNDLE_NAME= Colors
+ BUNDLE_EXTENSION= .prefs
+
+-BUNDLE_INSTALL_DIR= $(GNUSTEP_INSTALLATION_DIR)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
+
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ Colors_LANGUAGES= \
+ English
+diff -Naur Preferences.orig/Modules/Colors/GNUmakefile.preamble Preferences/Modules/Colors/GNUmakefile.preamble
+--- Preferences.orig/Modules/Colors/GNUmakefile.preamble 2004-06-11 00:33:55.000000000 +0200
++++ Preferences/Modules/Colors/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -34,7 +34,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ ADDITIONAL_INSTALL_DIRS +=
+diff -Naur Preferences.orig/Modules/Defaults/GNUmakefile Preferences/Modules/Defaults/GNUmakefile
+--- Preferences.orig/Modules/Defaults/GNUmakefile 2003-08-16 19:19:29.000000000 +0200
++++ Preferences/Modules/Defaults/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -2,10 +2,10 @@
+
+ BUNDLE_NAME= Defaults
+ BUNDLE_EXTENSION= .prefs
+-BUNDLE_INSTALL_DIR= $(GNUSTEP_INSTALLATION_DIR)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
+
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ Defaults_LANGUAGES= \
+ English
+diff -Naur Preferences.orig/Modules/Defaults/GNUmakefile.preamble Preferences/Modules/Defaults/GNUmakefile.preamble
+--- Preferences.orig/Modules/Defaults/GNUmakefile.preamble 2003-08-16 19:35:57.000000000 +0200
++++ Preferences/Modules/Defaults/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -34,7 +34,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ ADDITIONAL_INSTALL_DIRS +=
+diff -Naur Preferences.orig/Modules/Font/GNUmakefile Preferences/Modules/Font/GNUmakefile
+--- Preferences.orig/Modules/Font/GNUmakefile 2005-10-12 02:02:36.000000000 +0200
++++ Preferences/Modules/Font/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -3,10 +3,10 @@
+ BUNDLE_NAME= Font
+ BUNDLE_EXTENSION= .prefs
+
+-BUNDLE_INSTALL_DIR= $(GNUSTEP_INSTALLATION_DIR)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
+
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ Font_LANGUAGES= \
+ English \
+diff -Naur Preferences.orig/Modules/Font/GNUmakefile.preamble Preferences/Modules/Font/GNUmakefile.preamble
+--- Preferences.orig/Modules/Font/GNUmakefile.preamble 2003-08-16 19:35:57.000000000 +0200
++++ Preferences/Modules/Font/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -34,7 +34,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ ADDITIONAL_INSTALL_DIRS +=
+diff -Naur Preferences.orig/Modules/Keyboard/GNUmakefile Preferences/Modules/Keyboard/GNUmakefile
+--- Preferences.orig/Modules/Keyboard/GNUmakefile 2003-08-16 19:19:29.000000000 +0200
++++ Preferences/Modules/Keyboard/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -3,10 +3,10 @@
+ BUNDLE_NAME= Keyboard
+ BUNDLE_EXTENSION= .prefs
+
+-BUNDLE_INSTALL_DIR= $(GNUSTEP_INSTALLATION_DIR)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
+
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ Keyboard_LANGUAGES= \
+ English
+diff -Naur Preferences.orig/Modules/Keyboard/GNUmakefile.preamble Preferences/Modules/Keyboard/GNUmakefile.preamble
+--- Preferences.orig/Modules/Keyboard/GNUmakefile.preamble 2003-08-16 19:35:57.000000000 +0200
++++ Preferences/Modules/Keyboard/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -34,7 +34,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ ADDITIONAL_INSTALL_DIRS +=
+diff -Naur Preferences.orig/Modules/Time/GNUmakefile Preferences/Modules/Time/GNUmakefile
+--- Preferences.orig/Modules/Time/GNUmakefile 2003-08-16 19:19:29.000000000 +0200
++++ Preferences/Modules/Time/GNUmakefile 2007-11-06 15:48:49.000000000 +0100
+@@ -2,10 +2,10 @@
+
+ BUNDLE_NAME= Time
+ BUNDLE_EXTENSION= .prefs
+-BUNDLE_INSTALL_DIR= $(GNUSTEP_INSTALLATION_DIR)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
+
+ FRAMEWORKS= PrefsModule
+-include $(TOP_SRCDIR)/Backbone.make
++
+
+ Time_LANGUAGES= \
+ English
+diff -Naur Preferences.orig/Modules/Time/GNUmakefile.preamble Preferences/Modules/Time/GNUmakefile.preamble
+--- Preferences.orig/Modules/Time/GNUmakefile.preamble 2003-08-16 19:35:57.000000000 +0200
++++ Preferences/Modules/Time/GNUmakefile.preamble 2007-11-06 15:48:49.000000000 +0100
+@@ -34,7 +34,7 @@
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
++
+
+ # Additional directories to be created during installation
+ ADDITIONAL_INSTALL_DIRS +=
diff --git a/gnustep-apps/preferences/metadata.xml b/gnustep-apps/preferences/metadata.xml
new file mode 100644
index 000000000000..388502d78636
--- /dev/null
+++ b/gnustep-apps/preferences/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+Preferences.app
+A modular GNUstep preferences editor
+</longdescription>
+</pkgmetadata>
diff --git a/gnustep-apps/preferences/preferences-1.3.0_pre20061204-r1.ebuild b/gnustep-apps/preferences/preferences-1.3.0_pre20061204-r1.ebuild
new file mode 100644
index 000000000000..618a8fcf8374
--- /dev/null
+++ b/gnustep-apps/preferences/preferences-1.3.0_pre20061204-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/p/P}
+
+DESCRIPTION="Preferences is the GNUstep program with which you define your own personal user experience"
+HOMEPAGE="http://www.nongnu.org/backbone/apps.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+
+DEPEND="~gnustep-libs/prefsmodule-1.1.1${PV/*_/_}"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/Preferences-nocreate-extra-dirs.patch
+ epatch "${FILESDIR}"/${PN}-gnustep-make2.patch
+}
+
+src_install() {
+# egnustep_env
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}/Colors
+ gnustep-base_src_install
+}
diff --git a/gnustep-apps/preferences/preferences-1.3.0_pre20100523.ebuild b/gnustep-apps/preferences/preferences-1.3.0_pre20100523.ebuild
new file mode 100644
index 000000000000..6cd4b1005743
--- /dev/null
+++ b/gnustep-apps/preferences/preferences-1.3.0_pre20100523.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/p/P}
+
+DESCRIPTION="Preferences is the GNUstep program with which you define your own personal user experience"
+HOMEPAGE="http://www.nongnu.org/backbone/apps.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="gnustep-libs/prefsmodule"
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e 's#include $(TOP_SRCDIR)/Backbone.make##' GNUmakefile \
+ Modules/*/GNUmakefile || die "backbone sed failed"
+}