summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild')
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild
index 0c14906ff59c..9cacbd62ad4c 100644
--- a/gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild
+++ b/gnustep-base/gnustep-make/gnustep-make-2.6.8.ebuild
@@ -96,13 +96,8 @@ src_configure() {
src_compile() {
emake
- # Prepare doc here (needed when no gnustep-make is already installed)
if use doc ; then
- # If a gnustep-1 environment is set
- unset GNUSTEP_MAKEFILES
- pushd Documentation &> /dev/null
- emake -j1 all install
- popd &> /dev/null
+ emake -C Documentation
fi
}
@@ -118,9 +113,7 @@ src_install() {
# Copy the documentation
if use doc ; then
- dodir ${GNUSTEP_SYSTEM_DOC}
- cp -r Documentation/tmp-installation/System/Library/Documentation/* \
- "${ED}"${GNUSTEP_SYSTEM_DOC=}
+ emake -C Documentation ${make_eval} DESTDIR="${D}" install
fi
dodoc FAQ README RELEASENOTES