summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kdebase-data/kdebase-data-4.14.3-r1.ebuild')
-rw-r--r--kde-apps/kdebase-data/kdebase-data-4.14.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-apps/kdebase-data/kdebase-data-4.14.3-r1.ebuild b/kde-apps/kdebase-data/kdebase-data-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..430f3bb1e52f
--- /dev/null
+++ b/kde-apps/kdebase-data/kdebase-data-4.14.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase"
+IUSE="+wallpapers"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ wallpapers? ( $(add_kdeapps_dep kde-wallpapers) )
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+PATCHES=( "${FILESDIR}/${P}-lithuania-euro.patch" )
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}