summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kmag/kmag-19.08.1.ebuild')
-rw-r--r--kde-apps/kmag/kmag-19.08.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-apps/kmag/kmag-19.08.1.ebuild b/kde-apps/kmag/kmag-19.08.1.ebuild
new file mode 100644
index 000000000000..0aadc01359ff
--- /dev/null
+++ b/kde-apps/kmag/kmag-19.08.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="KDE screen magnifier"
+HOMEPAGE="https://kde.org/applications/utilities/kmag/"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="keyboardfocus"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ keyboardfocus? ( >=media-libs/libqaccessibilityclient-0.4:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package keyboardfocus QAccessibilityClient)
+ )
+
+ kde5_src_configure
+}