summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-20.12.3-r1.ebuild102
-rw-r--r--kde-apps/dolphin/files/dolphin-20.12.3-fix-session-restore-w-o-tabs.patch70
-rw-r--r--kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch41
4 files changed, 0 insertions, 214 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 69f72c51e184..21c431a5a06e 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1 @@
-DIST dolphin-20.12.3.tar.xz 5134660 BLAKE2B 3ad3e7c16d0c4203e189bdf035028777115971091bc3c45a3e88231f9715c9439f44c67b2bf2d9d4680a07d222c0c14858028d54499fbe8cf006e3eae63a9193 SHA512 fb57121875fb6b3db9b3071590ea2b6fe7db1d22238af758591835946ac297d7a1734646385a2f6b7ade41de7dcfdf8f6b5e7dccf335a3cf558259d017e44a11
DIST dolphin-21.04.3.tar.xz 5228312 BLAKE2B cdfbde0789b5c2dfc31d61e8c37b47e82a31877da9437770c463149b33ee46d4b5b1866aa38b1991f12e878ea27f4424c6b162113d87a865e0bcd815941abd4e SHA512 bb7d2f342aecae3b424aef93591124a5ca041e5e75909ed43c6202bc7cf7ab0e34a883050194b6e71f71425b2116ee579e67016205a648de6d5e5b0d01bf3ea8
diff --git a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild b/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
deleted file mode 100644
index e9bec9cda97d..000000000000
--- a/kde-apps/dolphin/dolphin-20.12.3-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="forceoptional"
-ECM_TEST="true"
-PVCUT=$(ver_cut 1-3)
-KFMIN=5.75.0
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org optfeature
-
-DESCRIPTION="Plasma filemanager focusing on usability"
-HOMEPAGE="https://apps.kde.org/dolphin/ https://userbase.kde.org/Dolphin"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="amd64 arm64 ~ppc64 x86"
-IUSE="activities semantic-desktop telemetry"
-
-DEPEND="
- >=dev-qt/qtconcurrent-${QTMIN}:5
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kcmutils-${KFMIN}:5
- >=kde-frameworks/kcodecs-${KFMIN}:5
- >=kde-frameworks/kcompletion-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kinit-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5=
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/solid-${KFMIN}:5
- >=media-libs/phonon-4.11.0
- activities? ( >=kde-frameworks/kactivities-${KFMIN}:5 )
- semantic-desktop? (
- >=kde-apps/baloo-widgets-${PVCUT}:5
- >=kde-frameworks/baloo-${KFMIN}:5
- >=kde-frameworks/kfilemetadata-${KFMIN}:5
- )
- telemetry? ( dev-libs/kuserfeedback:5 )
-"
-RDEPEND="${DEPEND}
- >=kde-apps/kio-extras-${PVCUT}:5
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-session-restore-w-o-tabs.patch" # KDE-bug 434911
- # pending https://invent.kde.org/system/dolphin/-/merge_requests/208
- "${FILESDIR}/${PN}-21.04.1-fix-no-semantic-desktop.patch" # KDE-bug 435586
-)
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
- $(cmake_use_find_package activities KF5Activities)
- $(cmake_use_find_package semantic-desktop KF5Baloo)
- $(cmake_use_find_package semantic-desktop KF5BalooWidgets)
- $(cmake_use_find_package semantic-desktop KF5FileMetaData)
- $(cmake_use_find_package telemetry KUserFeedback)
- )
- ecm_src_configure
-}
-
-src_test() {
- local myctestargs=(
- # servicemenuinstaller requires ruby, no thanks
- # dolphinmainwindowtest, kitemlistcontrollertest, kfileitemlistviewtest, kfileitemmodeltest hang forever
- # placesitemmodeltest requires DBus
- -E "(servicemenuinstaller|dolphinmainwindowtest|kfileitemlistviewtest|kfileitemmodeltest|kitemlistcontrollertest|placesitemmodeltest)"
- )
- ecm_src_test
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- optfeature "compress/extract and other actions" kde-apps/ark:${SLOT}
- optfeature "crypto actions" kde-apps/kleopatra:${SLOT}
- optfeature "video file thumbnails" kde-apps/ffmpegthumbs:${SLOT}
- optfeature "graphics file thumbnails" kde-apps/thumbnailers:${SLOT}
- optfeature "'Share' context menu actions" kde-frameworks/purpose:${SLOT}
- fi
- ecm_pkg_postinst
-}
diff --git a/kde-apps/dolphin/files/dolphin-20.12.3-fix-session-restore-w-o-tabs.patch b/kde-apps/dolphin/files/dolphin-20.12.3-fix-session-restore-w-o-tabs.patch
deleted file mode 100644
index 9605bead03cf..000000000000
--- a/kde-apps/dolphin/files/dolphin-20.12.3-fix-session-restore-w-o-tabs.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 175538020824355115cd98637ce83ecc53badd44 Mon Sep 17 00:00:00 2001
-From: Nate Graham <nate@kde.org>
-Date: Thu, 18 Mar 2021 13:42:59 -0600
-Subject: [PATCH] Don't re-open already-open URLs when using session-restore
- feature
-
-If Dolphin would be asked to open a location that is already open, don't
-open it again in a new tab; instead switch to that view. Supports tabs
-and split view.
-
-BUG: 434911
-FIXED-IN: 21.04
----
- src/dolphintabwidget.cpp | 24 ++++++++++++++++++------
- 1 file changed, 18 insertions(+), 6 deletions(-)
-
-diff --git a/src/dolphintabwidget.cpp b/src/dolphintabwidget.cpp
-index d61a9f74f..17fa0ff4e 100644
---- a/src/dolphintabwidget.cpp
-+++ b/src/dolphintabwidget.cpp
-@@ -186,14 +186,20 @@ void DolphinTabWidget::openDirectories(const QList<QUrl>& dirs, bool splitView)
- {
- Q_ASSERT(dirs.size() > 0);
-
-+ bool somethingWasAlreadyOpen = false;
-+
- QList<QUrl>::const_iterator it = dirs.constBegin();
- while (it != dirs.constEnd()) {
- const QUrl& primaryUrl = *(it++);
- const QPair<int, bool> indexInfo = indexByUrl(primaryUrl);
- const int index = indexInfo.first;
- const bool isInPrimaryView = indexInfo.second;
-+
-+ // When the user asks for a URL that's already open, activate it instead
-+ // of opening a second copy
- if (index >= 0) {
-- setCurrentIndex(index);
-+ somethingWasAlreadyOpen = true;
-+ activateTab(index);
- const auto tabPage = tabPageAt(index);
- if (isInPrimaryView) {
- tabPage->primaryViewContainer()->setActive(true);
-@@ -204,13 +210,19 @@ void DolphinTabWidget::openDirectories(const QList<QUrl>& dirs, bool splitView)
- // Required for updateViewState() call in openFiles() to work as expected
- // If there is a selection, updateViewState() calls are effectively a no-op
- tabPage->activeViewContainer()->view()->clearSelection();
-- continue;
-- }
-- if (splitView && (it != dirs.constEnd())) {
-+ } else if (splitView) {
- const QUrl& secondaryUrl = *(it++);
-- openNewActivatedTab(primaryUrl, secondaryUrl);
-+ if (somethingWasAlreadyOpen) {
-+ openNewTab(primaryUrl, secondaryUrl);
-+ } else {
-+ openNewActivatedTab(primaryUrl, secondaryUrl);
-+ }
- } else {
-- openNewActivatedTab(primaryUrl);
-+ if (somethingWasAlreadyOpen) {
-+ openNewTab(primaryUrl);
-+ } else {
-+ openNewActivatedTab(primaryUrl);
-+ }
- }
- }
- }
---
-GitLab
-
diff --git a/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch b/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch
deleted file mode 100644
index 5636d0532ed4..000000000000
--- a/kde-apps/dolphin/files/dolphin-21.04.1-fix-no-semantic-desktop.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 29636baff0f0cf8d769aa75b1c458b96cf83b828 Mon Sep 17 00:00:00 2001
-From: Ismael Asensio <isma.af@gmail.com>
-Date: Sun, 9 May 2021 21:10:44 +0200
-Subject: [PATCH] search/facetswidget: Check for protocol before trying to
- fetch tags
-
-This was causing an error when trying to list items from the
-non-existent `tags:` protocol.
-
-BUG: 435586
-FIXED-IN: 21.04.1
----
- src/search/dolphinfacetswidget.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/search/dolphinfacetswidget.cpp b/src/search/dolphinfacetswidget.cpp
-index d4079f1eb..e8a43101f 100644
---- a/src/search/dolphinfacetswidget.cpp
-+++ b/src/search/dolphinfacetswidget.cpp
-@@ -8,6 +8,7 @@
- #include "dolphinfacetswidget.h"
-
- #include <KLocalizedString>
-+#include <KProtocolInfo>
-
- #include <QComboBox>
- #include <QDate>
-@@ -245,7 +246,9 @@ void DolphinFacetsWidget::updateTagsSelector()
- void DolphinFacetsWidget::updateTagsMenu()
- {
- updateTagsMenuItems({}, {});
-- m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
-+ if (KProtocolInfo::isKnownProtocol(QStringLiteral("tags"))) {
-+ m_tagsLister.openUrl(QUrl(QStringLiteral("tags:/")), KCoreDirLister::OpenUrlFlag::Reload);
-+ }
- }
-
- void DolphinFacetsWidget::updateTagsMenuItems(const QUrl&, const KFileItemList& items)
---
-GitLab
-