summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-15.08.1.ebuild90
-rw-r--r--kde-apps/dolphin/files/dolphin-15.08.1-kactivities.patch29
3 files changed, 120 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index 08f6847e5e1c..b8a05dcb166d 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-15.08.0.tar.xz 656524 SHA256 7ac16d7150b7c5e1d6350cf679981d675c995303a7f68eab1290763d3fd35ad9 SHA512 485f5a888ef5f68014c9c33b8a0f63a0d9b20a65098b026714b1b7cf831751bf382430296ef43861d4259bb73f84251353855c60ca096acdb384d1947e8fed57 WHIRLPOOL 3a207189700c11287b2286b5dc017beea4040279849079b5d86a9ce7464023d19d6ba55818ce0a11f609242f01f19a2936ec626a211352944f848dd8646a224c
+DIST dolphin-15.08.1.tar.xz 656544 SHA256 5a5e895a1ccd6e423af2a349572658c34469102305c4d6469b047bbf3e29b926 SHA512 7b97028ff06a0117b93b5ea2035bda164cad2af85c9bc53cbf704cf6551d5191f4da08531fab180558d98dfdc37b46d99cb402becbf82d7263e87bc78287c54e WHIRLPOOL 6b6a7183ace01bc31a846e9dfcb2d75184ea8d158534ec31ce9ac96e494954c84d65a303a5c60fab5b3473086aeed1bb734ee5c04ba0e32be77b2ca53f067297
DIST kde-baseapps-4.14.3.tar.xz 2548152 SHA256 125baf42a7ab8c255b5829d12837f54c1791498f79593a9b09a9e55344ade6db SHA512 d422c1ee5cd2e1dc15b5baa2199bb85441196bc3048b9bfa443f898c3a1cfbc7f66087edf016fb594b9e48340517beef54b4429b4fde664374e75486c7cb0f9e WHIRLPOOL b22a98d140bb66ea47aeb5607e606c7a531c82787e27204f5eabb7d29d763b2bfe1456d85242d3e05e7ab4d2366fc622ef1cc624dd1954e276fb36c49840998a
diff --git a/kde-apps/dolphin/dolphin-15.08.1.ebuild b/kde-apps/dolphin/dolphin-15.08.1.ebuild
new file mode 100644
index 000000000000..5db5984b23bb
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-15.08.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+KDE_PUNT_BOGUS_DEPS="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ $(add_kdeapps_dep ffmpegthumbs '' 5.9999)
+ $(add_kdeapps_dep thumbnailers '' 5.9999)
+ )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-15.08.0-deps.patch"
+ "${FILESDIR}/${PN}-15.08.1-kactivities.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop KF5Baloo)
+ $(cmake-utils_use_with semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_with semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ( ! has_version kde-apps/ark:${SLOT} || ! has_version kde-apps/libkonq:${SLOT} ); then
+ echo
+ elog "For compress/extract actions, please install kde-apps/ark:${SLOT} and kde-apps/libkonq:${SLOT}"
+ echo
+ fi
+}
diff --git a/kde-apps/dolphin/files/dolphin-15.08.1-kactivities.patch b/kde-apps/dolphin/files/dolphin-15.08.1-kactivities.patch
new file mode 100644
index 000000000000..08cce3e26d6e
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-15.08.1-kactivities.patch
@@ -0,0 +1,29 @@
+From 6e218c4c146c08626c6bf4c87e9849a9de7462c4 Mon Sep 17 00:00:00 2001
+From: Michael Palimaka <kensington@gentoo.org>
+Date: Sat, 26 Sep 2015 05:34:26 +1000
+Subject: [PATCH] Fix KF5Activities being optional.
+
+If found via find_package(KF5 COMPONENTS Activities) instead, it will
+inherit REQUIRED from the previous call.
+
+REVIEW: 125360
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d98f261..d926e9f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -66,7 +66,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+ WindowSystem
+ Notifications
+ )
+-find_package(KF5 ${KF5_MIN_VERSION} COMPONENTS
++find_package(KF5 ${KF5_MIN_VERSION} OPTIONAL_COMPONENTS
+ Activities
+ )
+
+--
+2.4.9
+