summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.17.0.ebuild')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.17.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.17.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.17.0.ebuild
deleted file mode 100644
index 6a7af101d360..000000000000
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.17.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-KDE_AUTODEPS="false"
-KDE_DEBUG="false"
-inherit kde5 python-any-r1
-
-DESCRIPTION="Extra modules and scripts for CMake"
-HOMEPAGE="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
-
-LICENSE="BSD"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-IUSE="doc"
-
-DEPEND="
- >=dev-util/cmake-2.8.12
- doc? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]')
- )
-"
-RDEPEND="
- dev-qt/qtcore:5
-"
-
-python_check_deps() {
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_build doc HTML_DOCS)
- $(cmake-utils_use_build doc MAN_DOCS)
- )
-
- cmake-utils_src_configure
-}