summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/frameworkintegration/frameworkintegration-5.37.0.ebuild')
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.37.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.37.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.37.0.ebuild
deleted file mode 100644
index a8da9abf8f40..000000000000
--- a/kde-frameworks/frameworkintegration/frameworkintegration-5.37.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-VIRTUALX_REQUIRED="test"
-inherit kde5
-
-DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="appstream X"
-
-RDEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep knewstuff)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kpackage)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtwidgets)
- appstream? (
- app-admin/packagekit-qt
- dev-libs/appstream[qt5]
- )
- X? (
- $(add_qt_dep qtx11extras)
- x11-libs/libxcb
- )
-"
-DEPEND="${RDEPEND}"
-
-# requires running kde environment
-RESTRICT+=" test"
-
-src_prepare() {
- punt_bogus_dep Qt5 DBus
- kde5_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package appstream AppStreamQt)
- $(cmake-utils_use_find_package appstream packagekitqt5)
- $(cmake-utils_use_find_package X XCB)
- )
-
- kde5_src_configure
-}