summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcompletion/kcompletion-5.40.0.ebuild')
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.40.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/kcompletion-5.40.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.40.0.ebuild
new file mode 100644
index 000000000000..ccc50ad4d14a
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.40.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"