summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kcompletion')
-rw-r--r--kde-frameworks/kcompletion/Manifest1
-rw-r--r--kde-frameworks/kcompletion/kcompletion-5.65.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kcompletion/Manifest b/kde-frameworks/kcompletion/Manifest
index a6eebce3391d..7b8c133c4b0d 100644
--- a/kde-frameworks/kcompletion/Manifest
+++ b/kde-frameworks/kcompletion/Manifest
@@ -1 +1,2 @@
DIST kcompletion-5.64.0.tar.xz 119888 BLAKE2B 73ca4589b574659c0396aa2e2615ea586353b91fcef6393056005dcb8a63e04d47f66e81a583caaafc7c96dee2e12626b3a029eeb9c0f46576901a20c479205b SHA512 59f84af0130ca8954f557068e91c86317d7df2b593071aed07790ba7012005394c8180e9408bc686ffd476c14edb4d6f4e3758f7cb9983a4db00237c1dbe578f
+DIST kcompletion-5.65.0.tar.xz 120368 BLAKE2B 8fee8d0f108281474a27eb1bb88bea1c8641fe925ba60ffa8feb8051bfe672f520eb52e2d18fa8e249fdaeccc9d80a585517a3cae0343f6e97493693a56ab719 SHA512 d35844d13ab695ccf783a509dc0adcd7e39775ea6ebfa1ec2a1e21d81aa81eb422fc4df2c8bd71ba75f72b68c34d1d4a61801cbcc497834cc0d5cbb0dec39459
diff --git a/kde-frameworks/kcompletion/kcompletion-5.65.0.ebuild b/kde-frameworks/kcompletion/kcompletion-5.65.0.ebuild
new file mode 100644
index 000000000000..6b03498212b4
--- /dev/null
+++ b/kde-frameworks/kcompletion/kcompletion-5.65.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=kde-frameworks/kconfig-${PVCUT}:5
+ >=kde-frameworks/kwidgetsaddons-${PVCUT}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"