summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kdesignerplugin')
-rw-r--r--kde-frameworks/kdesignerplugin/Manifest1
-rw-r--r--kde-frameworks/kdesignerplugin/kdesignerplugin-5.66.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-frameworks/kdesignerplugin/Manifest b/kde-frameworks/kdesignerplugin/Manifest
index 7b76d34a8ae..f9c320d53e1 100644
--- a/kde-frameworks/kdesignerplugin/Manifest
+++ b/kde-frameworks/kdesignerplugin/Manifest
@@ -1,2 +1,3 @@
DIST kdesignerplugin-5.64.0.tar.xz 71080 BLAKE2B 4d60091cd64541e5e0af91b5ce2ed350188cad75f3bf58d12b90c77f82a9c912df0543a8f0d4b2371e7c378d0ce08fc327b356270225613ed2a0a873cc99133c SHA512 abaace216390f35d94bdf8f608b0d8bca475dc3bc0ab193d71774f4904669f86c7e8b600a390fd1470f3e8f57e52885aa89d7d38468644176006e72d981e83e1
DIST kdesignerplugin-5.65.0.tar.xz 71152 BLAKE2B 733c281b0ca6e67e09adf46583c8a75746eec364586700263d7d02846a8e6189650e79f27729c7ea5fda59d1cb264cde40daba9c45b1b4f55c90ca50ebec0ec4 SHA512 4caf89f2ea2b52697b967d3025217ac49d4dde8b475af8605e5a7a7e7014a7fb1d6da2433e8b3162e33eb1ed85bf8cdcb8c50cf5bb1de1cb9d4243754a90614a
+DIST kdesignerplugin-5.66.0.tar.xz 71108 BLAKE2B 32651814bff9f500c313a13fdd54d4c2da519395bdeb799cd480008e7b65b977eb1244588b603457750f2529dabce4102443665bf8ac0f4bd5eb6318479e44bf SHA512 04ed2b9a7c75be32d3f9ddd68f33e4a9c36620ffe80ee2d0599279d445d8236fa63f5a0ceb437fbf9cd8c180944178eff1d26e94fcb807441800a9ea0fd23b28
diff --git a/kde-frameworks/kdesignerplugin/kdesignerplugin-5.66.0.ebuild b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.66.0.ebuild
new file mode 100644
index 00000000000..da2a7c562f4
--- /dev/null
+++ b/kde-frameworks/kdesignerplugin/kdesignerplugin-5.66.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_QTHELP="false"
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework providing plugins to use KDE frameworks widgets in QtDesigner"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"