summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kf-env')
-rw-r--r--kde-frameworks/kf-env/kf-env-5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kf-env/kf-env-5.ebuild b/kde-frameworks/kf-env/kf-env-5.ebuild
new file mode 100644
index 000000000000..8e9bd4a05641
--- /dev/null
+++ b/kde-frameworks/kf-env/kf-env-5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Environment setting required for all KDE Frameworks apps to run"
+HOMEPAGE="https://community.kde.org/Frameworks"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-misc/xdg-utils-1.1.1-r1"
+
+S=${WORKDIR}
+
+src_install() {
+ einfo "Installing environment file..."
+
+ # higher number to be sure not to kill kde4 env
+ local envfile="${T}/78kf"
+
+ echo "CONFIG_PROTECT=${EPREFIX}/usr/share/config" >> ${envfile}
+ doenvd ${envfile}
+}