summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/ki18n/ki18n-5.31.0.ebuild')
-rw-r--r--kde-frameworks/ki18n/ki18n-5.31.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/ki18n/ki18n-5.31.0.ebuild b/kde-frameworks/ki18n/ki18n-5.31.0.ebuild
new file mode 100644
index 000000000000..7a231d5670be
--- /dev/null
+++ b/kde-frameworks/ki18n/ki18n-5.31.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-single-r1
+
+DESCRIPTION="Framework based on Gettext for internationalizing user interface text"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(add_qt_dep qtscript)
+ sys-devel/gettext
+ virtual/libintl
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdeclarative)
+ )
+"
+
+pkg_setup() {
+ kde5_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ kde5_src_install
+ python_fix_shebang "${ED}/usr/$(get_libdir)/cmake/KF5I18n/ts-pmap-compile.py"
+}