summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kwallet')
-rw-r--r--kde-frameworks/kwallet/Manifest1
-rw-r--r--kde-frameworks/kwallet/files/kwallet-5.13.0-migration.patch152
-rw-r--r--kde-frameworks/kwallet/kwallet-5.14.0.ebuild41
3 files changed, 0 insertions, 194 deletions
diff --git a/kde-frameworks/kwallet/Manifest b/kde-frameworks/kwallet/Manifest
index b190de649296..2a6e734fab87 100644
--- a/kde-frameworks/kwallet/Manifest
+++ b/kde-frameworks/kwallet/Manifest
@@ -1,3 +1,2 @@
-DIST kwallet-5.14.0.tar.xz 284616 SHA256 9eda8d24256d57caf8eb6bc30c02f6a7ef860b2157e09a4f7f9e9710abaa61ea SHA512 9efc0b767a9a4b714b0c649cf52652d2a284e126c53f15e308dd01d19109694dea8ffdb04aa93fad6572141c53c1fb9b604ef96e6638f0cdfd84277726c86cac WHIRLPOOL 33690717c13a75214093618eaaa27ef8f8d69dc7dc49aa4ff0fb6429f9639d4c10078aad53e845642b01058dfed3b5081d370d55de14380dc38e614b0e8e23a6
DIST kwallet-5.15.0.tar.xz 285324 SHA256 220d997fdc87c42a1a836d8f39fffafeb384499df113e0aacc9f9ea636d927ad SHA512 824d1c49a78e147a4b75087452709f9d5ac0936feafbfb3f3922e302642e13848983caafbfddd6be17a535347db730e89fdeb9753852718710de61ea74376f17 WHIRLPOOL 8a2bdcf722ad17607779fe63f1dab3955d8e30bb0a8377cafb6c3646d8c4a871f9714dcda675bcd3ebbf32b78fc699f2aaeeec39889fc6bc223c09ee2022bd4d
DIST kwallet-5.16.0.tar.xz 286028 SHA256 f1893d87607aaed6c532a2c05149f220df1795acf50a20d71bca178cea619cbd SHA512 b386f77165df2f3a4820b0ee2f7c5214252701fe341bedef0ef5b90976549d9b9692b43e0423b036e9c174711010bd3de2719b8e3e6dd7d8d0be4b8cb1db1cc8 WHIRLPOOL 014f2a8ce32ebcb051c6def27623ac4fec174cda81f3b5339961aee29836f92ee15e4d73209f796b390875355213efd29d7f27c998524ade90c3ce05eff6524c
diff --git a/kde-frameworks/kwallet/files/kwallet-5.13.0-migration.patch b/kde-frameworks/kwallet/files/kwallet-5.13.0-migration.patch
deleted file mode 100644
index 760a1674015f..000000000000
--- a/kde-frameworks/kwallet/files/kwallet-5.13.0-migration.patch
+++ /dev/null
@@ -1,152 +0,0 @@
-From 127efedd1668b546d0ac8c83655a2056d0439f29 Mon Sep 17 00:00:00 2001
-From: Valentin Rusu <kde@rusu.info>
-Date: Fri, 7 Aug 2015 18:59:04 +0200
-Subject: [PATCH] Stop showing the migration wizard by default
-
-BUG:351056
-
-If the migration wizard is needed, then add this to kwalletrc
-[Migration]
-showMigrationWizard=true
-
-On systems having kwallet-pam the migration agent would also merge all the old
-wallets into the default LocalWallet, as a side effect. This would avoid
-wallet creation prompts, though.
----
- src/runtime/kwalletd/main.cpp | 2 +-
- src/runtime/kwalletd/migrationagent.cpp | 42 ++++++++++++++++++++++++++------
- src/runtime/kwalletd/migrationagent.h | 5 ++--
- src/runtime/kwalletd/migrationwizard.cpp | 2 +-
- 4 files changed, 39 insertions(+), 12 deletions(-)
-
-diff --git a/src/runtime/kwalletd/main.cpp b/src/runtime/kwalletd/main.cpp
-index c0fecaa..62fcd3a 100644
---- a/src/runtime/kwalletd/main.cpp
-+++ b/src/runtime/kwalletd/main.cpp
-@@ -186,7 +186,7 @@ int main(int argc, char **argv)
- aboutdata.addAuthor(i18n("Thiago Maceira"), i18n("D-Bus Interface"), "thiago@kde.org");
-
- KWalletD walletd;
-- MigrationAgent migrationAgent(&walletd);
-+ MigrationAgent migrationAgent(&walletd, hash);
- KDBusService dbusUniqueInstance(KDBusService::Unique | KDBusService::NoExitOnFailure);
-
- // NOTE: the command should be parsed only after KDBusService instantiation
-diff --git a/src/runtime/kwalletd/migrationagent.cpp b/src/runtime/kwalletd/migrationagent.cpp
-index 6eaeb12..192a871 100644
---- a/src/runtime/kwalletd/migrationagent.cpp
-+++ b/src/runtime/kwalletd/migrationagent.cpp
-@@ -34,10 +34,12 @@
-
- #define SERVICE_KWALLETD4 "org.kde.kwalletd"
- #define ENTRY_ALREADY_MIGRATED "alreadyMigrated"
-+#define ENTRY_SHOW_MIGRATION_WIZARD "showMigrationWizard"
-
--MigrationAgent::MigrationAgent(KWalletD* kd) :
-+MigrationAgent::MigrationAgent(KWalletD* kd, const char *hash) :
- _kf5_daemon(kd)
- , _kde4_daemon(0)
-+ , _pam_hash(hash)
- {
- QTimer::singleShot(100, this, SLOT(migrateWallets()));
- }
-@@ -118,11 +120,27 @@ bool MigrationAgent::isMigrationWizardOk()
- {
- bool ok = false;
-
-- MigrationWizard *wizard = new MigrationWizard(this);
-- int result = wizard->exec();
-- if (QDialog::Accepted == result) {
-- // the user either migrated the wallets, or choose not to be prompted again
-- ok = true;
-+ // The migration wizard would no longer been shown by default.
-+ // see BUG 351056
-+ // NOTE if user wants to show the migration wizard, then he should add the
-+ // following setting to the kwalletrc:
-+ // [Migration]
-+ // showMigrationWizard=true
-+ KConfig kwalletrc("kwalletrc");
-+ KConfigGroup cfg(&kwalletrc, "Migration");
-+ bool showMigrationWizard = cfg.readEntry<bool>(ENTRY_SHOW_MIGRATION_WIZARD, false);
-+
-+ if (showMigrationWizard) {
-+ MigrationWizard *wizard = new MigrationWizard(this);
-+ int result = wizard->exec();
-+ if (QDialog::Accepted == result) {
-+ // the user either migrated the wallets, or choose not to be prompted again
-+ ok = true;
-+ }
-+ } else {
-+ if (performMigration(0, true)) {
-+ qDebug() << "Migration failed.";
-+ }
- }
-
- return ok;
-@@ -162,7 +180,7 @@ bool MigrationAgent::isEmptyOldWallet() const {
- return wallets.length() == 0;
- }
-
--bool MigrationAgent::performMigration(WId wid)
-+bool MigrationAgent::performMigration(WId wid, bool withoutWizard)
- {
- auto appId = i18n("KDE Wallet Migration Agent");
- try {
-@@ -174,7 +192,15 @@ bool MigrationAgent::performMigration(WId wid)
- emit progressMessage(i18n("Migrating wallet: %1", wallet));
- emit progressMessage(i18n("* Creating KF5 wallet: %1", wallet));
-
-- int handle5 = _kf5_daemon->internalOpen(appId, wallet, false, 0, true, QString());
-+ int handle5 = -1;
-+ if (withoutWizard && (_pam_hash != nullptr)) {
-+ // see BUG 351056 for why this hacky code
-+ // If the user has several wallets, all the values will be
-+ // merged into the single LocalWallet
-+ handle5 = _kf5_daemon->pamOpen(KWallet::Wallet::LocalWallet(), _pam_hash, 0);
-+ } else {
-+ handle5 = _kf5_daemon->internalOpen(appId, wallet, false, 0, true, QString());
-+ }
- if (handle5 <0) {
- emit progressMessage(i18n("ERROR when attempting new wallet creation. Aborting."));
- return false;
-diff --git a/src/runtime/kwalletd/migrationagent.h b/src/runtime/kwalletd/migrationagent.h
-index 55a251d..c52509e 100644
---- a/src/runtime/kwalletd/migrationagent.h
-+++ b/src/runtime/kwalletd/migrationagent.h
-@@ -32,10 +32,10 @@ class KWalletD;
- class MigrationAgent : public QObject {
- Q_OBJECT
- public:
-- MigrationAgent(KWalletD* kd);
-+ MigrationAgent(KWalletD* kd, const char* hash);
-
- bool isEmptyOldWallet() const;
-- bool performMigration(WId wid);
-+ bool performMigration(WId wid, bool withoutWizard);
-
- private Q_SLOTS:
- void migrateWallets();
-@@ -52,6 +52,7 @@ Q_SIGNALS:
- private:
- KWalletD *_kf5_daemon;
- org::kde::KWallet *_kde4_daemon;
-+ const char *_pam_hash;
- };
-
- #endif // _MIGRATIONAGENT_H_
-diff --git a/src/runtime/kwalletd/migrationwizard.cpp b/src/runtime/kwalletd/migrationwizard.cpp
-index b7d3f70..cdd2a92 100644
---- a/src/runtime/kwalletd/migrationwizard.cpp
-+++ b/src/runtime/kwalletd/migrationwizard.cpp
-@@ -58,7 +58,7 @@ public:
-
- virtual void initializePage() {
- connect(_agent, SIGNAL(progressMessage(QString)), _ui._report, SLOT(append(QString)));
-- _migrationCompleted = _agent->performMigration(winId());
-+ _migrationCompleted = _agent->performMigration(winId(), false);
- emit completeChanged();
- }
-
---
-2.4.6
-
diff --git a/kde-frameworks/kwallet/kwallet-5.14.0.ebuild b/kde-frameworks/kwallet/kwallet-5.14.0.ebuild
deleted file mode 100644
index 9af54c76a59d..000000000000
--- a/kde-frameworks/kwallet/kwallet-5.14.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit kde5
-
-DESCRIPTION="Framework providing desktop-wide storage for passwords"
-LICENSE="LGPL-2+"
-KEYWORDS="~amd64 ~x86"
-IUSE="gpg"
-
-RDEPEND="
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep knotifications)
- $(add_frameworks_dep kservice)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kwindowsystem)
- dev-libs/libgcrypt:0=
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- gpg? (
- $(add_kdeapps_dep gpgmepp)
- app-crypt/gpgme
- )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package gpg Gpgme)
- $(cmake-utils_use_find_package gpg KF5Gpgmepp)
- )
- kde5_src_configure
-}