summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.75.0-krunner-terribly-slow-input.patch45
-rw-r--r--kde-frameworks/plasma/plasma-5.75.0-r1.ebuild78
2 files changed, 123 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.75.0-krunner-terribly-slow-input.patch b/kde-frameworks/plasma/files/plasma-5.75.0-krunner-terribly-slow-input.patch
new file mode 100644
index 000000000000..8e25425627ba
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.75.0-krunner-terribly-slow-input.patch
@@ -0,0 +1,45 @@
+From e0e7840a0307deaee7a0b63f341973f8e3508873 Mon Sep 17 00:00:00 2001
+From: Aleix Pol <aleixpol@kde.org>
+Date: Thu, 8 Oct 2020 16:35:39 +0200
+Subject: [PATCH] BusyIndicator: Do not rotate when invisible
+
+It seems like the "visible" property is catching there is the wrong one
+and would still rotate while invisible.
+
+CCBUG: 426746
+
+From d578c2a1540a52ff9ccbb0658dc24b9be394bbd9 Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fabian@ritter-vogt.de>
+Date: Sat, 17 Oct 2020 13:45:15 +0200
+Subject: [PATCH] Fix BusyIndicator rotating even when invisible, again
+
+After "BusyIndicator: Do not rotate when invisible", plasmashell started
+consuming 100% CPU due to plasma-nm's icon having an invisible BusyIndicator.
+Adding the "visible" property back into the equation avoids this.
+
+Third time's the charm?
+---
+ src/declarativeimports/plasmacomponents3/BusyIndicator.qml | 3 +-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/declarativeimports/plasmacomponents3/BusyIndicator.qml b/src/declarativeimports/plasmacomponents3/BusyIndicator.qml
+index ec4ccaf13..6321d88cf 100644
+--- a/src/declarativeimports/plasmacomponents3/BusyIndicator.qml
++++ b/src/declarativeimports/plasmacomponents3/BusyIndicator.qml
+@@ -25,6 +25,7 @@
+ padding: 0
+
+ contentItem: Item {
++ id: baseItem
+ /* implicitWidth and implicitHeight won't work unless they come
+ * from a child of the contentItem. No idea why.
+ */
+@@ -61,7 +62,7 @@
+ to: 360
+ duration: 2000
+ loops: Animation.Infinite
+- running: visible
++ running: visible && (control.running || baseItem.opacity > 0)
+ }
+ }
+ }
diff --git a/kde-frameworks/plasma/plasma-5.75.0-r1.ebuild b/kde-frameworks/plasma/plasma-5.75.0-r1.ebuild
new file mode 100644
index 000000000000..d3b855483a16
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.75.0-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gles2-only wayland X"
+
+BDEPEND="
+ >=kde-frameworks/kdoctools-${PVCUT}:5
+"
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ !gles2-only? ( virtual/opengl )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/mesa[egl]
+ )
+ X? (
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-krunner-terribly-slow-input.patch # KDE-Bug 426746
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ $(cmake_use_find_package X X11)
+ $(cmake_use_find_package X XCB)
+ )
+
+ ecm_src_configure
+}