summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch')
-rw-r--r--kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch b/kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch
new file mode 100644
index 000000000000..f72b0963e3fb
--- /dev/null
+++ b/kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch
@@ -0,0 +1,21 @@
+commit e9ddacb58dcf011bc2a877c11b026cab94031e65
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sat May 27 15:58:32 2017 +0200
+
+ If tests are optional, autotests subdir must be conditional
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0c1b691..a2a771c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -61,7 +61,9 @@ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+ add_definitions(-DQT_STRICT_ITERATORS)
+ add_definitions(-DTRANSLATION_DOMAIN=\"kio5_gdrive\")
+
+-add_subdirectory(autotests)
++if(BUILD_TESTING)
++ add_subdirectory(autotests)
++endif()
+ add_subdirectory(desktop)
+ add_subdirectory(doc)
+ add_subdirectory(src)