summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/wacomtablet/files/wacomtablet-3.2.0-qt-5.15.patch24
-rw-r--r--kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/kde-misc/wacomtablet/files/wacomtablet-3.2.0-qt-5.15.patch b/kde-misc/wacomtablet/files/wacomtablet-3.2.0-qt-5.15.patch
new file mode 100644
index 000000000000..572450b0b113
--- /dev/null
+++ b/kde-misc/wacomtablet/files/wacomtablet-3.2.0-qt-5.15.patch
@@ -0,0 +1,24 @@
+From 4f73ff02b3efd5e8728b18fcf1067eca166704ee Mon Sep 17 00:00:00 2001
+From: Christophe Giboudeaux <christophe@krop.fr>
+Date: Thu, 4 Jun 2020 16:00:38 +0200
+Subject: Fix build with Qt 5.15
+
+---
+ src/kcmodule/pressurecurvewidget.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/kcmodule/pressurecurvewidget.cpp b/src/kcmodule/pressurecurvewidget.cpp
+index 0c943b3..f047a6c 100644
+--- a/src/kcmodule/pressurecurvewidget.cpp
++++ b/src/kcmodule/pressurecurvewidget.cpp
+@@ -22,6 +22,7 @@
+ //Qt includes
+ #include <QDebug>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QMouseEvent>
+ #include <QResizeEvent>
+ #include <QTabletEvent>
+--
+cgit v1.1
+
diff --git a/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
index fb00967bfb2e..9f284009c8c1 100644
--- a/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
+++ b/kde-misc/wacomtablet/wacomtablet-3.2.0.ebuild
@@ -45,6 +45,8 @@ DEPEND="${RDEPEND}
x11-libs/libX11
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.15.patch" )
+
src_test() {
# test needs DBus, bug 675548
local myctestargs=(