summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.5.0-favourites-migration.patch26
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.5.0-r1.ebuild (renamed from kde-plasma/plasma-desktop/plasma-desktop-5.5.0.ebuild)2
2 files changed, 28 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.5.0-favourites-migration.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.5.0-favourites-migration.patch
new file mode 100644
index 000000000000..60dd2377f7c5
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.5.0-favourites-migration.patch
@@ -0,0 +1,26 @@
+From 97ced66da372737ae5d36d86c9bc0c6fe684d842 Mon Sep 17 00:00:00 2001
+From: Eike Hein <hein@kde.org>
+Date: Tue, 8 Dec 2015 20:26:26 +0100
+Subject: [PATCH] Fix migration of multiple favorites.
+
+BUG:356398
+---
+ desktoppackage/contents/updates/obsolete_kickoffrc.js | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/desktoppackage/contents/updates/obsolete_kickoffrc.js b/desktoppackage/contents/updates/obsolete_kickoffrc.js
+index aae077f..d92cae9 100644
+--- a/desktoppackage/contents/updates/obsolete_kickoffrc.js
++++ b/desktoppackage/contents/updates/obsolete_kickoffrc.js
+@@ -1,7 +1,7 @@
+ var kickoffConfig = ConfigFile("kickoffrc");
+
+ kickoffConfig.group = "Favorites";
+-var favorites = kickoffConfig.readEntry("FavoriteURLs");
++var favorites = kickoffConfig.readEntry("FavoriteURLs").split(',');
+
+ kickoffConfig.group = "SystemApplications";
+ var systemApplications = kickoffConfig.readEntry("DesktopFiles").split(',');
+--
+2.4.10
+
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.5.0.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.5.0-r1.ebuild
index cdf749a0f5aa..59ec709f7306 100644
--- a/kde-plasma/plasma-desktop/plasma-desktop-5.5.0.ebuild
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.5.0-r1.ebuild
@@ -118,6 +118,8 @@ DEPEND="${COMMON_DEPEND}
REQUIRED_USE="legacy-systray? ( || ( gtk2 gtk3 qt4 ) ) gtk2? ( legacy-systray ) gtk3? ( legacy-systray )"
+PATCHES=( "${FILESDIR}/${P}-favourites-migration.patch" )
+
pkg_setup() {
if has_version net-im/skype && use legacy-systray && use amd64; then
einfo