summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-cairo-xlib.patch47
-rw-r--r--lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-no-undefined.patch25
-rw-r--r--lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r2.ebuild (renamed from lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild)16
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild (renamed from lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild)0
-rw-r--r--lxde-base/lxdm/files/lxdm-0.5.3-portable-msghdr.patch18
-rw-r--r--lxde-base/lxdm/lxdm-0.5.3-r4.ebuild (renamed from lxde-base/lxdm/lxdm-0.5.3-r3.ebuild)22
-rw-r--r--lxde-base/lxdm/metadata.xml5
-rw-r--r--lxde-base/lxpanel/lxpanel-0.10.1.ebuild3
-rw-r--r--lxde-base/lxpanel/metadata.xml1
-rw-r--r--lxde-base/lxterminal/metadata.xml1
-rw-r--r--lxde-base/metadata.xml4
11 files changed, 125 insertions, 17 deletions
diff --git a/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-cairo-xlib.patch b/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-cairo-xlib.patch
new file mode 100644
index 000000000000..7098f98ca50f
--- /dev/null
+++ b/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-cairo-xlib.patch
@@ -0,0 +1,47 @@
+From: orbea <orbea@riseup.net>
+Date: Mon, 11 Jul 2022 17:38:52 -0700
+Subject: [PATCH] build: Add missing cairo-xlib dependency
+
+src/preview.c:146:15: warning: implicit declaration of function ‘cairo_xlib_surface_create’; did you mean ‘cairo_image_surface_create’? [-Wimplicit-function-declaration]
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -16,6 +16,7 @@ module_LTLIBRARIES = src/obconf.la
+ moduledir = $(libdir)/lxappearance/plugins
+
+ src_obconf_la_CPPFLAGS = \
++ $(CAIRO_CFLAGS) \
+ $(OPENBOX_CFLAGS) \
+ $(GTK_CFLAGS) \
+ $(LXAPPEARANCE_CFLAGS) \
+@@ -30,6 +31,7 @@ src_obconf_la_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"Obconf\"
+
+ src_obconf_la_LIBADD = \
++ $(CAIRO_LIBS) \
+ $(OPENBOX_LIBS) \
+ $(GTK_LIBS) \
+ $(LXAPPEARANCE_LIBS) \
+--- a/configure.ac
++++ b/configure.ac
+@@ -89,6 +89,10 @@ PKG_CHECK_MODULES(OPENBOX, [obrender-3.5 >= 3.5 obt-3.5 >= 3.5])
+ AC_SUBST(OPENBOX_CFLAGS)
+ AC_SUBST(OPENBOX_LIBS)
+
++PKG_CHECK_MODULES(CAIRO, [cairo-xlib])
++AC_SUBST(CAIRO_CFLAGS)
++AC_SUBST(CAIRO_LIBS)
++
+ if test "x$enable_gtk3" = "xyes" ; then
+ CFLAGS="$CFLAGS -DENABLE_GTK3"
+ gtk_modules="gtk+-3.0 >= 3.0.0"
+--- a/src/preview.c
++++ b/src/preview.c
+@@ -27,6 +27,7 @@
+
+ #include <string.h>
+
++#include <cairo/cairo-xlib.h>
+ #include <obrender/theme.h>
+
+ #if GTK_CHECK_VERSION(3, 0, 0)
diff --git a/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-no-undefined.patch b/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-no-undefined.patch
new file mode 100644
index 000000000000..4e94157ac7a0
--- /dev/null
+++ b/lxde-base/lxappearance-obconf/files/lxappearance-obconf-0.2.3-no-undefined.patch
@@ -0,0 +1,25 @@
+Bug: https://bugs.gentoo.org/779484
+
+From: orbea <orbea@riseup.net>
+Date: Mon, 11 Jul 2022 17:23:36 -0700
+Subject: [PATCH] build: Remove -no-undefined
+
+This depends on lxappearance_changed which is only available in the
+lxappearence binary and will be undefined at build time. Additionally
+GNU libtool silently ignores -no-undefined allowing the build to work
+while slibtool will respect it as expected.
+
+The easiest way to solve this is to just remove -no-undefined since it
+is not respected anyways.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -126,7 +126,7 @@ AC_SUBST(LXAPPEARANCE_LIBDIR)
+ AC_SUBST(LXAPPEARANCE_DATADIR)
+
+ LXAPPEARANCE_MODULE="-avoid-version \
+- -no-undefined "'-export-symbols-regex "^[[^_]].*"'
++ "'-export-symbols-regex "^[[^_]].*"'
+ AC_SUBST(LXAPPEARANCE_MODULE)
+
+ if test x"$enable_more_warnings" = x"yes"; then
diff --git a/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild b/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r2.ebuild
index 96b2c49bd9a0..11f52b57e993 100644
--- a/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r1.ebuild
+++ b/lxde-base/lxappearance-obconf/lxappearance-obconf-0.2.3-r2.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="LXAppearance plugin for configuring OpenBox"
HOMEPAGE="https://lxde.org/"
@@ -21,7 +23,7 @@ RDEPEND="
media-libs/fontconfig
media-libs/freetype:2
media-libs/harfbuzz:=
- x11-libs/cairo
+ x11-libs/cairo[X]
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/libICE
@@ -37,6 +39,16 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-undefined.patch # 779484
+ "${FILESDIR}"/${P}-cairo-xlib.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--disable-static \
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild
index bdd7fc588a95..bdd7fc588a95 100644
--- a/lxde-base/lxappearance/lxappearance-0.6.3-r2.ebuild
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild
diff --git a/lxde-base/lxdm/files/lxdm-0.5.3-portable-msghdr.patch b/lxde-base/lxdm/files/lxdm-0.5.3-portable-msghdr.patch
new file mode 100644
index 000000000000..dc7f8ad016e9
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.5.3-portable-msghdr.patch
@@ -0,0 +1,18 @@
+--- a/src/lxcom.c
++++ b/src/lxcom.c
+@@ -117,7 +117,15 @@
+ char ctrl[/*CMSG_SPACE(sizeof(LXDM_CRED))*/1024];
+ struct sockaddr_un peer;
+ struct iovec v={buf,sizeof(buf)};
+- struct msghdr h={&peer,sizeof(peer),&v,1,ctrl,sizeof(ctrl),0};
++ struct msghdr h={
++ .msg_name = &peer,
++ .msg_namelen = sizeof(peer),
++ .msg_iov = &v,
++ .msg_iovlen = 1,
++ .msg_control = ctrl,
++ .msg_controllen = sizeof(ctrl),
++ .msg_flags = 0
++ };
+ struct cmsghdr *cmptr;
+ int ret;
diff --git a/lxde-base/lxdm/lxdm-0.5.3-r3.ebuild b/lxde-base/lxdm/lxdm-0.5.3-r4.ebuild
index 2c6641a0a084..f4ccc1ad9647 100644
--- a/lxde-base/lxdm/lxdm-0.5.3-r3.ebuild
+++ b/lxde-base/lxdm/lxdm-0.5.3-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,10 +19,10 @@ IUSE="debug elogind nls pam systemd"
# They are directly referenced in the C code of the greeter and config util
DEPEND="
dev-libs/glib:2
- x11-libs/cairo
+ x11-libs/cairo[X(-)]
x11-libs/gdk-pixbuf:2
- x11-libs/gtk+:3
- x11-libs/pango
+ x11-libs/gtk+:3[X(-)]
+ x11-libs/pango[X(-)]
x11-libs/libX11
x11-libs/libxcb:0=
virtual/libcrypt:0=
@@ -42,15 +42,19 @@ DOCS=( AUTHORS README TODO )
REQUIRED_USE="?? ( elogind systemd ) elogind? ( pam ) systemd? ( pam )"
+PATCHES=(
+ # Fix consolekit and selinux
+ "${FILESDIR}/${P}-pam.patch"
+ # Apply all upstream fixes in git until 2016-11-11
+ "${FILESDIR}/lxdm-0.5.3-upstream-fixes.patch"
+ "${FILESDIR}/lxdm-0.5.3-portable-msghdr.patch"
+)
+
src_prepare() {
# Upstream bug, tarball contains pre-made lxdm.conf
rm "${S}"/data/lxdm.conf || die
- # Fix consolekit and selinux
- eapply "${FILESDIR}/${P}-pam.patch"
- # Apply all upstream fixes in git until 2016-11-11
- eapply "${FILESDIR}/lxdm-0.5.3-upstream-fixes.patch"
- eapply_user
+ default
# this replaces the bootstrap/autogen script in most packages
eautoreconf
diff --git a/lxde-base/lxdm/metadata.xml b/lxde-base/lxdm/metadata.xml
index 346eccc47865..b9095c9781d0 100644
--- a/lxde-base/lxdm/metadata.xml
+++ b/lxde-base/lxdm/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>grknight@gentoo.org</email>
- <name>Brian Evans</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">lxde</remote-id>
</upstream>
diff --git a/lxde-base/lxpanel/lxpanel-0.10.1.ebuild b/lxde-base/lxpanel/lxpanel-0.10.1.ebuild
index 07a5a63d4cf2..a14fb1325cd6 100644
--- a/lxde-base/lxpanel/lxpanel-0.10.1.ebuild
+++ b/lxde-base/lxpanel/lxpanel-0.10.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,7 +49,6 @@ src_configure() {
use wifi && plugins+=",netstat"
use alsa && plugins+=",volumealsa"
- [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
econf \
$(use_enable alsa) \
diff --git a/lxde-base/lxpanel/metadata.xml b/lxde-base/lxpanel/metadata.xml
index eb6c52bb507a..51f4bde82c2b 100644
--- a/lxde-base/lxpanel/metadata.xml
+++ b/lxde-base/lxpanel/metadata.xml
@@ -4,5 +4,6 @@
<!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">lxde</remote-id>
+ <remote-id type="github">lxde/lxpanel</remote-id>
</upstream>
</pkgmetadata>
diff --git a/lxde-base/lxterminal/metadata.xml b/lxde-base/lxterminal/metadata.xml
index f683ae020a16..6ad96d09fde7 100644
--- a/lxde-base/lxterminal/metadata.xml
+++ b/lxde-base/lxterminal/metadata.xml
@@ -4,5 +4,6 @@
<!-- maintainer-needed -->
<upstream>
<remote-id type="sourceforge">lxde</remote-id>
+ <remote-id type="github">lxde/lxterminal</remote-id>
</upstream>
</pkgmetadata>
diff --git a/lxde-base/metadata.xml b/lxde-base/metadata.xml
index 8b1b3a82f7ce..345385d7f76a 100644
--- a/lxde-base/metadata.xml
+++ b/lxde-base/metadata.xml
@@ -5,6 +5,10 @@
The lxde-base category contains core packages for LXDE,
the Lightweight X11 Desktop Environment.
</longdescription>
+ <longdescription lang="de">
+ Die Kategorie lxde-base enthält grundlegende Pakete für LXDE,
+ das "Lightweight X11 Desktop Environment".
+ </longdescription>
<longdescription lang="es">
La categoría lxde-base contiene paquetes vitales para LXDE, el
entorno de escritorio ligero X11.