summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/alot')
-rw-r--r--mail-client/alot/Manifest1
-rw-r--r--mail-client/alot/alot-0.3.7.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/mail-client/alot/Manifest b/mail-client/alot/Manifest
index 55c4496826eb..ea64befd1d0b 100644
--- a/mail-client/alot/Manifest
+++ b/mail-client/alot/Manifest
@@ -1 +1,2 @@
DIST alot-0.3.6.tar.gz 1492278 SHA256 b8e6092f18e503a528e934231c448db0e03d00e11d844192ba7eeb483838fee7 SHA512 30037ca1d2c169dda6c1660a24dadee12c6b5858d733ec7cd78e49d633850eecb763852c16565340596e32a6831ff8c36764d3f812de7f7947584defe05322b4 WHIRLPOOL cd4aab9dd84a441b92f5d4c62c783d58d8c4fafca614bf8bf462c1b3f0ffb4266e083380712b16f9469a0b418af1672625a21a6ae1f82f6623c6c22e005be6e9
+DIST alot-0.3.7.tar.gz 1475759 SHA256 fe281f6b5fbfcd371a1810c8f59084e8cbc3f69068269e3f787adb1df6f977b5 SHA512 a0b7e5a7b77f8cdee38c273eec2822bee2e7c409ab4b8803817a49d679dd53ff29750ba7f8a9214368cc7b0b17bd76a40b0263b4701b2ef695c7669316b1b116 WHIRLPOOL 3c37a037fc5543ff569f6a5364302462f71f5599c14d17661707cd4beb0e2a8597098dd4f4a42aec27793ace7095bba4eb80c35ed5fd8e470f6b7b9dbbecc46e
diff --git a/mail-client/alot/alot-0.3.7.ebuild b/mail-client/alot/alot-0.3.7.ebuild
new file mode 100644
index 000000000000..7579a5aa680a
--- /dev/null
+++ b/mail-client/alot/alot-0.3.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+SRC_URI="${HOMEPAGE}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ "
+RDEPEND="
+ >=dev-python/configobj-4.6.0[${PYTHON_USEDEP}]
+ dev-python/pygpgme[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-10.2.0
+ >=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.13[crypt,python]
+ sys-apps/file[python]
+ "
+
+ALOT_UPDATE=""
+
+pkg_setup() {
+ if has_version "<${CATEGORY}/${PN}-0.3.2"; then
+ ALOT_UPDATE="yes"
+ fi
+}
+
+src_prepare() {
+ find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
+ -e '1i# -*- coding: utf-8 -*-' -i || die
+
+ distutils-r1_src_prepare
+
+ local md
+ for md in *.md; do
+ mv "${md}" "${md%.md}"
+ done
+}
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc; then
+ pushd docs || die
+ emake html
+ popd || die
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodir /usr/share/alot
+ insinto /usr/share/alot
+ doins -r extra
+
+ if use doc; then
+ dohtml -r docs/build/html/*
+ fi
+}
+
+pkg_postinst() {
+ if [[ ${ALOT_UPDATE} = yes ]]; then
+ ewarn "The syntax of theme-files and custom tags-sections of the config"
+ ewarn "has been changed. You have to revise your config. There are"
+ ewarn "converter scripts in /usr/share/alot/extra to help you out with"
+ ewarn "this:"
+ ewarn ""
+ ewarn " * tagsections_convert.py for your ~/.config/alot/config"
+ ewarn " * theme_convert.py to update your custom theme files"
+ fi
+}