summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/Manifest1
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r8.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/mail-client/mail-notification/Manifest b/mail-client/mail-notification/Manifest
index cd19b8f7c028..bb8c8a4399c4 100644
--- a/mail-client/mail-notification/Manifest
+++ b/mail-client/mail-notification/Manifest
@@ -1,2 +1 @@
DIST mail-notification-9ae8768.tar.gz 573948 SHA256 632c0b696f3f3878b497d65d944b1778ea379abcb4536fb6285c0035ae984db3 SHA512 57ddeb63816dd1db1b732dd13fedeb366e1d82f070feb3f9cf854a85a0e66ab2a60a92126fa57cdc338df699e304007dd84593ea1d6185b08c21a018e441629b WHIRLPOOL 3e11a7094bcb62c5384a13671e5bd96c27d230de20c130463520c6ac1b105b86e875dc9feb1b23dafd5579d9576483347a7bad5c18108efe3cccebdb68caaf87
-DIST mail-notification-eab5c13.tar.gz 569791 SHA256 12f79cfaa6f5bbfa68e2a5e8dca651cfe19ed017741c21bec5b3b91bccecffe6 SHA512 fe4b5c7b04fe24950fcff0796dbe27c0172e9e8c1b1229f18064ae3720d12a669803e08796ac61d64912847eaaccc451363d69cecd55995274c5a0b2705a78f1 WHIRLPOOL 480179b855b7b86cb80b750c14c034e2f52b280a4b1b6e6aeed3c64b722808c7bd0086e75a9a0423d71424ffa37b3752da2b170c3b7af13697b77cafaceabb25
diff --git a/mail-client/mail-notification/mail-notification-5.4-r8.ebuild b/mail-client/mail-notification/mail-notification-5.4-r8.ebuild
deleted file mode 100644
index 43bd96b1ca1e..000000000000
--- a/mail-client/mail-notification/mail-notification-5.4-r8.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-GCONF_DEBUG="no"
-
-inherit gnome2 eutils multilib flag-o-matic toolchain-funcs
-
-DESCRIPTION="Status icon informing about new mail"
-HOMEPAGE="http://www.nongnu.org/mailnotify/ https://github.com/epienbroek/mail-notification"
-
-GIT_REVISION="eab5c13" # Same as Fedora
-SRC_URI="https://github.com/epienbroek/${PN}/tarball/${GIT_REVISION} -> ${PN}-${GIT_REVISION}.tar.gz"
-S="${WORKDIR}/epienbroek-${PN}-${GIT_REVISION}"
-
-KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-linux"
-SLOT="0"
-LICENSE="GPL-3"
-IUSE="+gnome-keyring sasl +sound ssl sylpheed"
-
-LANGS="bg ca cs de es fr ja nl pl pt pt_BR ru sr sr@Latn sv"
-for lang in ${LANGS}; do
- IUSE+=" linguas_${lang}"
-done
-
-# gmime is actually optional, but it's used by so much of the package
-# it's pointless making it optional. gnome-keyring is required for
-# several specific access methods, and thus linked to those USE flags
-# instead of adding a keyring USE flag.
-RDEPEND="
- x11-libs/gtk+:3
- >=dev-libs/glib-2.14:2
- >=gnome-base/gconf-2.6
- >=gnome-base/libgnomeui-2.14
- dev-libs/dbus-glib
- dev-libs/gmime:2.6
- >=x11-libs/libnotify-0.4.1
- gnome-keyring? ( gnome-base/libgnome-keyring )
- ssl? ( >=dev-libs/openssl-0.9.6 )
- sasl? ( >=dev-libs/cyrus-sasl-2 )
- sound? ( media-libs/gstreamer:0.10 )
- sylpheed? ( mail-client/sylpheed )
-"
-DEPEND="${RDEPEND}
- app-text/scrollkeeper
- dev-util/gob
- sys-devel/gettext
- virtual/pkgconfig
- >=dev-util/intltool-0.35.0
-"
-# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
-# instead of autotools, this is a little helper function that basically does
-# the same thing as use_enable
-use_var() {
- echo "${2:-$1}=$(usex $1)"
-}
-
-src_prepare() {
- sed -i -e '/jb_rule_set_install_message/d' \
- -e '/jb_rule_add_install_command/d' \
- jbsrc/jb.c || die
-
- # Ensure we never append -Werror
- sed -i -e 's/ -Werror//' jb jbsrc/jb.c || die
-
- # We are not Ubuntu, and this could be the cause of #215281
- epatch "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
-
- # Apply Fedora patches
- # Fix gcc warning
- epatch "${FILESDIR}/${PN}-jb-gcc-format.patch"
- # Support aarch64
- epatch "${FILESDIR}/${PN}-aarch64.patch"
- # Fix build with latest libc
- epatch "${FILESDIR}/${PN}-dont-link-against-bsd-compat.patch"
-}
-
-src_configure() {
- set -- \
- ./jb configure destdir="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" \
- sysconfdir="${EPREFIX}/etc" localstatedir="${EPREFIX}/var" cc="$(tc-getCC)" \
- cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
- scrollkeeper-dir="${EPREFIX}/var/lib/scrollkeeper" \
- $(use_var gnome-keyring gmail) \
- $(use_var gnome-keyring imap) \
- $(use_var gnome-keyring pop3) \
- $(use_var sasl) \
- $(use_var ssl) \
- $(use_var sylpheed)
- echo "$@"
- "$@" || die
-}
-
-src_compile() {
- ./jb build || die
-}
-
-src_install() {
- GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install || die
- dodoc NEWS README AUTHORS TODO TRANSLATING
- rm -rf "${ED}/var/lib/scrollkeeper"
-
- einfo "Cleaning up locales..."
- for lang in ${LANGS}; do
- use "linguas_${lang}" && {
- einfo "- keeping ${lang}"
- continue
- }
- rm -Rf "${D}"/usr/share/locale/"${lang}" || die
- done
-}